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MAGELLAN NAVIGATION

PROFESSIONAL PRODUCTS - LIMITED WARRANTY

(North, Central and South America)
Magellan Navigation warrants their GPS receivers and 
hardware accessories to be free of defects in material and 
workmanship and will conform to our published 
specifications for the product for a period of one year from 
the date of original purchase. THIS WARRANTY APPLIES 
ONLY TO THE ORIGINAL PURCHASER OF THIS 
PRODUCT.
In the event of a defect, Magellan Navigation will, at its 
option, repair or replace the hardware product with no 
charge to the purchaser for parts or labor. The repaired or 
replaced product will be warranted for 90 days from the 
date of return shipment, or for the balance of the original 
warranty, whichever is longer. Magellan Navigation 
warrants that software products or software included in 
hardware products will be free from defects in the media 
for a period of 30 days from the date of shipment and will 
substantially conform to the then-current user 
documentation provided with the software (including 
updates thereto). Magellan Navigation's sole obligation 
shall be the correction or replacement of the media or the 
software so that it will substantially conform to the then- 
current user documentation. Magellan Navigation does 
not warrant the software will meet purchaser's 
requirements or that its operation will be uninterrupted, 
error-free or virus-free. Purchaser assumes the entire risk 
of using the software.
PURCHASER'S EXCLUSIVE REMEDY UNDER THIS 
WRITTEN WARRANTY OR ANY IMPLIED WARRANTY 
SHALL BE LIMITED TO THE REPAIR OR REPLACEMENT, 
AT MAGELLAN NAVIGATION'S OPTION, OF ANY 
DEFECTIVE PART OF THE RECEIVER OR ACCESSORIES 
WHICH ARE COVERED BY THIS WARRANTY. REPAIRS 
UNDER THIS WARRANTY SHALL ONLY BE MADE AT AN 
AUTHORIZED MAGELLAN NAVIGATION SERVICE 
CENTER. ANY REPAIRS BY A SERVICE CENTER NOT 
AUTHORIZED BY MAGELLAN NAVIGATION WILL VOID 
THIS WARRANTY.
To obtain warranty service the purchaser must obtain a 
Return Materials Authorization (RMA) number prior to 
shipping by calling 800-229-2400, option 1 (U.S.) or 
408-615-3981 (International), or by submitting a repair 
request on-line at http://professional.magellangps.com/
en/support/rma.asp. The purchaser must return the 
product postpaid with a copy of the original sales receipt 
to the address provided by Magellan Navigation with the 
RMA number. Purchaser's return address and the RMA 
number must be clearly printed on the outside of the 
package.
Magellan Navigation reserves the right to refuse to provide 
service free-of-charge if the sales receipt is not provided 
or if the information contained in it is incomplete or 
illegible or if the serial number is altered or removed. 
Magellan Navigation will not be responsible for any losses 
or damage to the product incurred while the product is in 
transit or is being shipped for repair. Insurance is 
recommended. Magellan Navigation suggests using a 
trackable shipping method such as UPS or FedEx when 
returning a product for service.

EXCEPT AS SET FORTH IN THIS LIMITED WARRANTY, 
ALL OTHER EXPRESSED OR IMPLIED WARRANTIES, 
INCLUDING THOSE OF FITNESS FOR ANY PARTICULAR 
PURPOSE, MERCHANTABILITY OR NON-
INFRINGEMENT, ARE HEREBY DISCLAIMED AND IF 
APPLICABLE, IMPLIED WARRANTIES UNDER ARTICLE 
35 OF THE UNITED NATIONS CONVENTION ON 
CONTRACTS FOR THE INTERNATIONAL SALE OF 
GOODS. Some national, state, or local laws do not allow 
limitations on implied warranty or how long an implied 
warranty lasts, so the above limitation may not apply to 
you.
The following are excluded from the warranty coverage: (1) 
periodic maintenance and repair or replacement of parts 
due to normal wear and tear; (2) batteries and finishes; (3) 
installations or defects resulting from installation; (4) any 
damage caused by (i) shipping, misuse, abuse, 
negligence, tampering, or improper use; (ii) disasters such 
as fire, flood, wind, and lightning; (iii) unauthorized 
attachments or modification; (5) service performed or 
attempted by anyone other than an authorized Magellan 
Navigations Service Center; (6) any product, components 
or parts not manufactured by Magellan Navigation; (7) 
that the receiver will be free from any claim for 
infringement of any patent, trademark, copyright or other 
proprietary right, including trade secrets; and (8) any 
damage due to accident, resulting from inaccurate 
satellite transmissions. Inaccurate transmissions can 
occur due to changes in the position, health or geometry 
of a satellite or modifications to the receiver that may be 
required due to any change in the GPS. (Note: Magellan 
Navigation GPS receivers use GPS or GPS+GLONASS to 
obtain position, velocity and time information. GPS is 
operated by the U.S. Government and GLONASS is the 
Global Navigation Satellite System of the Russian 
Federation, which are solely responsible for the accuracy 
and maintenance of their systems. Certain conditions can 
cause inaccuracies which could require modifications to 
the receiver. Examples of such conditions include but are 
not limited to changes in the GPS or GLONASS 
transmission.) Opening, dismantling or repairing of this 
product by anyone other than an authorized Magellan 
Navigation Service Center will void this warranty.
MAGELLAN NAVIGATION SHALL NOT BE LIABLE TO 
PURCHASER OR ANY OTHER PERSON FOR ANY 
INCIDENTAL OR CONSEQUENTIAL DAMAGES 
WHATSOEVER, INCLUDING BUT NOT LIMITED TO LOST 
PROFITS, DAMAGES RESULTING FROM DELAY OR 
LOSS OF USE, LOSS OF OR DAMAGES ARISING OUT OF 
BREACH OF THIS WARRANTY OR ANY IMPLIED 
WARRANTY EVEN THOUGH CAUSED BY NEGLIGENCE 
OR OTHER FAULT OF MAGELLAN NAVIGATION OR 
NEGLIGENT USAGE OF THE PRODUCT. IN NO EVENT 
WILL MAGELLAN NAVIGATION BE RESPONSIBLE FOR 
SUCH DAMAGES, EVEN IF MAGELLAN NAVIGATION 
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.
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This written warranty is the complete, final and exclusive 
agreement between Magellan Navigation and the 
purchaser with respect to the quality of performance of 
the goods and any and all warranties and representations. 
This warranty sets forth all of Magellan Navigation's 
responsibilities regarding this product. This limited 
warranty is governed by the laws of the State of California, 
without reference to its conflict of law provisions or the 
U.N. Convention on Contracts for the International Sale of 
Goods, and shall benefit Magellan Navigation, its 
successors and assigns.
This warranty gives the purchaser specific rights. The 
purchaser may have other rights which vary from locality 
to locality (including Directive 1999/44/EC in the EC 
Member States) and certain limitations contained in this 
warranty, including the exclusion or limitation of 
incidental or consequential damages may not apply. 
For further information concerning this limited warranty, 
please call or write:
Magellan Navigation, Inc., 960 Overland Court, San 
Dimas, CA 91773, Phone: +1 909-394-5000, Fax: +1 
909-394-7050 or
Magellan Navigation SA - ZAC La Fleuriaye - BP 433 - 
44474 Carquefou Cedex - France Phone: +33 (0)2 28 09 
38 00, Fax: +33 (0)2 28 09 39 39

MAGELLAN NAVIGATION

PROFESSIONAL PRODUCTS LIMITED WARRANTY

(Europe, Middle East, Africa)
All Magellan Navigation global positioning system (GPS) 
receivers are navigation aids, and are not intended to 
replace other methods of navigation. Purchaser is advised 
to perform careful position charting and use good 
judgment. READ THE USER GUIDE CAREFULLY BEFORE 
USING THE PRODUCT.
1. MAGELLAN NAVIGATION WARRANTY
Magellan Navigation warrants their GPS receivers and 
hardware accessories to be free of defects in material and 
workmanship and will conform to our published 
specifications for the product for a period of one year from 
the date of original purchase or such longer period as 
required by law. THIS WARRANTY APPLIES ONLY TO 
THE ORIGINAL PURCHASER OF THIS PRODUCT. 
In the event of a defect, Magellan Navigation will, at its 
option, repair or replace the hardware product with no 
charge to the purchaser for parts or labor. The repaired or 
replaced product will be warranted for 90 days from the 
date of return shipment, or for the balance of the original 
warranty, whichever is longer. Magellan Navigation 
warrants that software products or software included in 
hardware products will be free from defects in the media 
for a period of 30 days from the date of shipment and will 
substantially conform to the then-current user 
documentation provided with the software (including 
updates thereto). Magellan Navigation's sole obligation 
shall be the correction or replacement of the media or the 
software so that it will substantially conform to the then- 
current user documentation. Magellan Navigation does 
not warrant the software will meet purchaser's 
requirements or that its operation will be uninterrupted, 
error-free or virus-free. Purchaser assumes the entire risk 
of using the software.

2. PURCHASER'S REMEDY
PURCHASER'S EXCLUSIVE REMEDY UNDER THIS 
WRITTEN WARRANTY OR ANY IMPLIED WARRANTY 
SHALL BE LIMITED TO THE REPAIR OR REPLACEMENT, 
AT MAGELLAN NAVIGATION'S OPTION, OF ANY 
DEFECTIVE PART OF THE RECEIVER OR ACCESSORIES 
WHICH ARE COVERED BY THIS WARRANTY. REPAIRS 
UNDER THIS WARRANTY SHALL ONLY BE MADE AT AN 
AUTHORIZED MAGELLAN NAVIGATION SERVICE 
CENTER. ANY REPAIRS BY A SERVICE CENTER NOT 
AUTHORIZED BY MAGELLAN NAVIGATION WILL VOID 
THIS WARRANTY.
3. PURCHASER'S DUTIES
To obtain service, contact and return the product with a 
copy of the original sales receipt to the dealer from whom 
you purchased the product.
Magellan Navigation reserves the right to refuse to provide 
service free-of-charge if the sales receipt is not provided 
or if the information contained in it is incomplete or 
illegible or if the serial number is altered or removed. 
Magellan Navigation will not be responsible for any losses 
or damage to the product incurred while the product is in 
transit or is being shipped for repair. Insurance is 
recommended. Magellan Navigation suggests using a 
trackable shipping method such as UPS or FedEx when 
returning a product for service.
4. LIMITATION OF IMPLIED WARRANTIES
EXCEPT AS SET FORTH IN ITEM 1 ABOVE, ALL OTHER 
EXPRESSED OR IMPLIED WARRANTIES, INCLUDING 
THOSE OF FITNESS FOR ANY PARTICULAR PURPOSE 
OR MERCHANTABILITY, ARE HEREBY DISCLAIMED 
AND IF APPLICABLE, IMPLIED WARRANTIES UNDER 
ARTICLE 35 OF THE UNITED NATIONS CONVENTION 
ON CONTRACTS FOR THE INTERNATIONAL SALE OF 
GOODS. 
Some national, state, or local laws do not allow limitations 
on implied warranty or how long an implied warranty lasts, 
so the above limitation may not apply to you.
5. EXCLUSIONS
The following are excluded from the warranty coverage: 
(1) periodic maintenance and repair or replacement of 
parts due to normal wear and tear; 
(2) batteries; 
(3) finishes; 
(4) installations or defects resulting from installation; 
(5) any damage caused by (i) shipping, misuse, abuse, 
negligence, tampering, or improper use; (ii) disasters such 
as fire, flood, wind, and lightning; (iii) unauthorized 
attachments or modification; 
(6) service performed or attempted by anyone other than 
an authorized Magellan Navigations Service Center; 
(7) any product, components or parts not manufactured by 
Magellan Navigation, 
(8) that the receiver will be free from any claim for 
infringement of any patent, trademark, copyright or other 
proprietary right, including trade secrets 
(9) any damage due to accident, resulting from inaccurate 
satellite transmissions. Inaccurate transmissions can 
occur due to changes in the position, health or geometry 
of a satellite or modifications to the receiver that may be 
required due to any change in the GPS. (Note: Magellan 
Navigation GPS receivers use GPS or GPS+GLONASS to 
obtain position, velocity and time information. GPS is 
operated by the U.S. Government and GLONASS is the 
Global Navigation Satellite System of the Russian 
Federation, which are solely responsible for the accuracy 
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PC
1. Introduction

MobileMapper Office is an office software suite that interfaces 
Magellan GPS/GIS handheld receivers with your GIS system. 
MobileMapper Office allows you to prepare GIS jobs, feature 
libraries and waypoint files, build background maps from GIS 
data files and manage the information logged in the field (up-
load/download functions).
The MobileMapper Office software and its main functions are 
fully described in this manual, including all functions relative 
to data exchange between these receivers and MobileMapper 
Office.

MobileMapper Office’s main functions are listed below:
- Creating new job files by importing data from your GIS. 

The imported GIS data can be in SHP, MIF or DXF format.
- Uploading job files to the receiver so field operators can 

revisit previously completed jobs. When you do that, not 
only do you upload GPS positions and descriptions of the 
previously visited features but also the complete feature 
library associated with this job, and any waypoint/route 
file currently open in MobileMapper Office.

- Downloading completed job files from the receiver. Again, 
when you do that, the complete feature library associated 
with this job is downloaded in addition to the GPS posi-
tions and descriptions of the visited features.
1
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- Exporting jobs in GIS format (SHP, MIF, DXF or CSV).
- Creating standalone feature libraries using the Feature 

Library Editor. GIS layers can be imported from your GIS 
system when you create a feature library.

- Creating lists of waypoints and routes using the Waypoint/
Route Editor.

- Creating background maps using the Background Map and 
Map Editor utilities. You create a background map by 
importing data from SHP, DXF or MIF files (vector map) or 
from TIF, GTIF, BMP, JPG, JPEG, PNG or GIF files (raster 
map). Remember however that background maps are for 
viewing only.
You cannot edit them or access information on the fea-
tures shown on a background map. Background maps pro-
vide a backdrop, which gives visual orientation for your 
data and waypoint files. If you want to edit the positions or 
descriptions of a SHP, MIF or DXF file, you should import 
them into an MMJ job file.

- Uploading standalone feature libraries and background 

maps to the receiver. The relevant files can only be 
uploaded one by one.

- Downloading standalone feature libraries and waypoints/

routes from the receiver. The relevant files can only be 
downloaded one by one.

- Handling a coordinate system database from which you 
can specify the coordinate system MobileMapper Office 
should use to calculate the features and waypoints coordi-
nates. 
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2. Installing MobileMapper Office

If this is the first time you are installing MobileMapper Office, 
follow these steps:
- Close all applications running in Windows
- Insert the installation disk in the PC’s CD-ROM drive
- Find and double-click the “Setup” file. After you specify 

where to install the MobileMapper Office programs, and 
you agree to the terms of the software license, your com-
puter will complete the installation process.

If you are updating a previously installed version of 
MobileMapper Office, you should uninstall the older version 
before updating to the new version. To uninstall 
MobileMapper Office, follow these steps:
- On the Windows task bar, click on Start>Settings>Control 

Panel
- Double-click on Add/Remove Programs
- Highlight MobileMapper Office and click on the Remove but-

ton
- Now follow the instructions in the previous section to 

install the new version of MobileMapper Office. 
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3. Launching MobileMapper 
Office

On the Window task bar, select successively Start, Programs 
and MobileMapper Office. This starts the program causing the 
main window to open on the PC screen, along with the Tip of 
the Day window. First read the content of this window if you are 
interested in learning a new tip, and then click the Close 
button to access MobileMapper Office’s functions.
You may alternatively start just the Feature Library Editor, the 
MobileMapper Transfer utility, the Mission Planning program 
or this User Manual in order to open these modules on a 
standalone basis.
You may also launch MobileMapper Office from Windows 
Explorer or your desktop by double-clicking on any file with 
the .MMJ extension. 



4.MobileMapper Office
Main Window

The main window of MobileMapper Office is organized as 
explained below (see also above figure):
- The Map Display area runs from the bottom of the Menu 

bar to the bottom border. It takes up about two-thirds of 
the screen, right to left.

- At the bottom of the window, in the status bar, a box is 
used for displaying the geographic location of the cursor in 
the selected coordinate system, the current scale value 
and the name of the currently used coordinate system.

Map Display area

Layer List

Job Properties
5
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- The right third of the window is used to display the Job 
Properties and Layer List windows. When opened, the win-
dow relevant to the Waypoints or Routes List is placed over 
the right pane. When you click on any feature on the map, 
the Feature Properties window replaces the Job Properties 
window.

- The Map Editor and the Feature Library Editor are each 
displayed in a secondary window that appears at the cen-
ter of the screen. 



5.Map Display Area

Controlling the Content of the Map Dis-

play Area

The map display area shows data collected in the field, 
waypoints and GIS files imported into either job files or 
background maps.
MobileMapper Office also displays a very low-resolution map 
of the world showing coastlines, national boundaries and 
centroids of major cities. You use this coarse world map to 
help you select a spot on the globe and then zoom in to view 
data collected in that area and/or background maps created 
out of local files.
The data displayed in the Map Display area is controlled by 
the Layers List shown on the right-hand area, at the bottom of 
the main window.
When you want one of the listed layers displayed in the Map 
Display area, just fill in the check box located before this layer 
name. As a result, all the items pertaining to this layer will be 
shown in the Map Display area. Conversely, if you clear the 
check box, none of these items will be visible. If you double-
click on a checked layer name, you will optimize the Map 
Display area settings (pan and scale) in order to obtain the 
best possible view of all the items pertaining to this layer.
By default, the following two layers are always displayed:
- Waypoints
- Background map
7
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The grid lines and labels
will reflect the choice of

the coordinate system
used. However, all fea-

tures will be PLACED on
the map only based on

their WGS 84 coordi-
nates.
If a job is open, each feature type from the feature library used 
in the job also appears as a layer which can be displayed/
hidden on the Map Display area.
If you import a MIF or SHP file from your GIS system, then 
new layers will also be added to the Layer list.
In addition, you can change the look of these layers on the 
Map Display area by double-clicking on their names in the Job 
Properties window. Different icons are available for point 
features and different colors and styles are available for line, 
area and grid features.
Changing the appearance of feature types will change their 
appearance in the receiver as well.
A number of viewing options are also available from the 
bottom of the Options menu to let you customize the Map 
Display area. You can for example show/hide the grid values, 
the scale interval, the feature and waypoint labels, etc.
Below is the list of icons from the Map toolbar that you can 
use to work on the content the Map Display area:

: Allow you to respectively zoom in, zoom out 
and fit the scale to the map content (zoom to full extent). 
If your mouse includes a wheel button, you can also zoom 
in by rolling the wheel toward you or zoom out by rolling 
the wheel away from you.

: Allows you to adjust the scale to preset values 
(i.e. Previous Scale, Country, State, Region, City or Street) 
or zoom to a user-defined scale factor



: Allows you to drag the map in any direction.

: Allows you to select the map of a continent for dis-
play in the Map Display area as a backdrop to the job data 
(and also to the background map itself, if displayed).

: Displays/hides the differential correction pane. It is 
made available only if the open job was recorded using the 
post-processing mode.

: Gives access to the Background Maps dialog from 
which you can attach/detach a background map for the 
currently open job

: (Gives access to the Feature Library Editor window; 
not a map-related button)

: Allows you to measure distances on the map. See 
next chapter.

: Allows you to define a region within a job file or back-
ground map

: Switches the Waypoint window on and allows you to 
place new waypoints on the Map Display area

: Allows you to draw routes connecting waypoints 
shown on the map

: Allows you to upload jobs and background maps to 
the receiver and download jobs, waypoints and routes from 
the receiver.
9
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Making Measurements

on the Map Display Area

Step-by-Step Procedure
You can measure the distance and heading between any 
points displayed in the Map Display area:

- On the toolbar, click , then click on the point on the 
map from which to start the measurement. The start point 
is then marked with a small square symbol.
The distance is zero and the units are whatever you have 
selected.The default is meters. Until you start moving the 
cursor, the Heading value is the magnetic declination of 
the selected location.

- Then, as you move the mouse cursor away from the start 
point, MobileMapper Office will calculate the length and 
heading from the current location of the cursor to this 
point. The heading is displayed in reference to magnetic 
North, as signified by the letter “m.” The precision levels 
(one-tenth of a small unit and one hundredth of a large 
unit) are not editable.

- If you click on a second point, a straight line will appear 
on the map between the start point and the second point. 
Note that MobileMapper Office will snap to the closest 
feature position if you clicked close enough to this fea-
ture.
MobileMapper Office will also start calculating the dis-
tance and heading from the current location of the cursor 
to the second point, plus the total length from the mea-
surement’s start point.



When you click on the second point, the heading dis-
played is the magnetic declination of the second point 
location.

- If you move the cursor after clicking on the second point, 
the Measure Distance tool will add a new leg to the total 
distance being calculated. If you want to delete the first 
leg(s) and begin measuring a new point-to-point distance, 
right-click once.

- To stop measuring distances and headings on the map, 
press the Esc key or slowly press the right-click button 
twice or, in the toolbar, release the Measure Distance but-
ton.

Units Used by the Measurement Tool
The unit used in distance measurements can be user-set: 
From the Options menu, select Units and choose the desired 
units. Note that when checked, the Large Units option, located 
at the bottom of this menu, lets MobileMapper Office choose 
a more appropriate distance unit when you are measuring long 
distances. For example, when you measure distances beyond 
1000 meters the units automatically switch to kilometers. If 
you switch to feet and mile using the above command, the 
units automatically switch to miles when the distance exceeds 
1 mile.

What the Tool Actually Measures
The Measure Distance Tool estimates the distance between 
points on a sphere of average Earth radius. The elevations of 
the points are not factored into the equation. Thus the 
receiver calculates the spherical distance rather than the 
horizontal or slope distance between the two positions.
11
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GPS Position Display Filter

The GPS Position Display Filter is another function available on 
the Options menu that helps you control the content of the 
Map Display area. It allows you to highlight point features - 
and point locations making up line and area features - that do 
NOT meet a set of requirements that you choose on a pop-up 
window. The GPS Position Display Filter highlights those points 
that you might wish to filter out, i.e. delete, from your job.
The features that will meet ALL your requirements will be 
represented as follows (see opposite):
- Points: will depend on chosen symbol
- GPS positions making up lines and areas: filled squares
- Lines and areas: lines joining up GPS positions.

The features that will not meet these requirements will be 
represented as follows (see opposite):
- Points: Chosen symbols are highlighted
- Positions making up line and area features: “x” symbols 

replacing squares
- Lines and areas: Red-highlighted lines connecting those 

individual point locations that exceed the filter criteria.



Note: The Correction
Method, Horizontal/Ver-

tical Errors, PDOP and #
of satellites filters are

greyed out when the Dis-
play all positions option

is checked.
Below is the list of requirements that you can freely choose 
after selecting the Options>GPS Position Display Filter function:
- Correction Method: Choose the type of position solutions 

you would like to emphasize in the Map Display area. 
There are 4 possible options: Autonomous, WAAS/EGNOS 
corrected, real-time DGPS or post-processed DGPS. You 
may select more than one option. For more information 
about the post-processed DGPS feature, please see Basics 
of Post-Processed Differential Correction on page 103.

- Horizontal/Vertical Errors: If these buttons are both checked, 
all post-processed point features positions whose esti-
mated accuracy exceeds the chosen values will be high-
lighted.

- PDOP <: All GPS positions calculated with a PDOP equal to 
or less than the specified one will meet this requirement.

- # of satellites: All GPS positions calculated from a number 
of satellites equal to or greater than the specified one will 
meet this requirement.

If you wish to remove the currently set filter, just check the 
Show all positions button and click OK.
Note that if you check this button, the dialog box will keep all 
your previous filter settings. This is to allow you to easily re-
apply the same filter if you wish. You will do that by simply 
clearing the Show all positions button and clicking OK.
Also, note that the filter is disabled whenever you open 
another job or create a new one (the Show all positions button 
is checked). 
13
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To create a feature
library, see explanations

from page 76.

To create waypoints and
routes, see explanations

from page 65.
6.Working on Job Files

Creating a New Job

Before you ask field operators to create a new job with their 
receivers, you just need to create the appropriate feature 
library and upload it to their handhelds. Field operators will 
then just have to create a new job based on this feature library.
You can also prepare an “empty” job using the procedure 
below and later ask field operators to work from that job. By 
“empty job” we mean “with no features logged yet in the job” 
but remember waypoints and routes (i.e. a *.mmw file) can 
possibly be associated with an empty job if the mmw file is 
open in MobileMapper Office when you upload the job to the 
receiver.
You create job files using the New command from the File 
menu. Select Save from the File menu, type in a name for the 
job and click the Save button to create a new *.mmj file in the 
Docs folder (default folder).
A job file cannot do without a feature library as field operators 
do need a feature library to complete their jobs. That is why 
you have to import a feature library –created earlier– into the 
job before uploading the job to the handheld. You can do that 
using the Import command from the File menu, specifying the 
Feature Library Files option in the Files of Type field, selecting 
the feature library to associate with the job and then clicking 
Open. As a result, all the feature types read from this library 
will appear as layers in the job.
You can also add waypoints and routes to be associated with 
the job. This is simply done by saving the job when waypoints/
routes are shown in the Map Display area.



To choose a coordinate
system, and for more

information on coordi-
nate systems, see expla-

nations from page 93.
The coordinate system used to display the job in 
MobileMapper Office will be the one currently selected. All 
jobs subsequently opened will be displayed in this same 
coordinate system until you select a different one.

Importing GIS Data Into a Job File

Step-by-Step Procedure
- Open a job in MobileMapper Office.

Launching MobileMapper Office automatically opens an 
empty, “untitled” job. As with Microsoft Office applica-
tions, you may name this job using the File>Save As func-
tion or you may open an existing job using the File>Open 
function. You may also open a job clicking on File and 
selecting one of the jobs listed at the bottom on the win-
dow that you have recently opened.

- Select File>Import.
This brings up a new window that allows you to select the 
file you want to import (see window example below):

1. Select the extension of the files you want to 
import: MMJ, MMF, waypoints/routes (MMW, 
XLS, TXT), SHP, MIF or DXF (Files of type field)

1

2

3

4

15
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2. Select the directory in which to search for files to 
import

3. Select the files you want to import
4. Click on the Open button. This action brings up a 

new window (see window example below) display-
ing some information on the selected file and 
requiring some actions on your part.

1. First, there is a box at the top of the window in 
which MobileMapper Office tells you which coor-
dinate system is used in the selected SHP file to 
describe the features it contains. This informa-
tion is read from the PRJ file associated with the 
SHP file (i.e. the PRJ file having the same name.) 
MobileMapper Office suggests that you use this 
system.

1
(2)

(3)

(4) 5



MobileMapper Office
DOES NOT search for a
coordinate system in its

database that would
have exactly the same

definition - with same or
different name- as the
the coordinate system

prompted in the Import
GIS Data window.
• If you do not have any particular idea on which 
coordinate system should be used, we recom-
mend you to keep the one prompted by 
MobileMapper Office. When you import the 
file, this system will be added to MobileMap-
per Office’s database and will also become the 
currently active coordinate system in MobileM-
apper Office.

• In contrast, if you know that this coordinate 
system already exists in MobileMapper Office’s 
database, but under a different name, you may 
not wish to add the prompted system to the 
database (because you know it would be a 
duplicate of an already existing one). In that 
case, you should select the “equivalent” coor-
dinate system from the database and so reject 
the prompted one.

The path to the SHP file is shown just under-
neath, including the file name. To the left of the 
layer name is the symbol that will be used to dis-
play the layer in MobileMapper Office. All the 
attributes contained in the file are then listed.

2. (Optional) Double-click on the layer name to 
change the symbol that will be used to display 
the layer on the Map Display area. You will be 
able to change it later on from the Job Properties 
window.

3. (Optional) Right-click on one of the attributes and 
click on Set as Feature Label if you want to select 
this particular attribute to display as a label on 
MobileMapper Office's Map Display area.
17
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The attribute name will be displayed in bold face 
and there will be a key icon next to it.

4. (Optional) Clear the check boxes for all these 
attributes you do not want to import into the job.

5. Click on the Import button to allow MobileMapper 
Office to import the GIS data into the job. When 
import is complete, MobileMapper Office displays 
the imported layer on the Map Display area and 
the name of this new layer appears on the right, 
in the Layer list. See screen example below:

About Imported Formats
- When you select the SHP option, MobileMapper Office 

imports the information included in all the following files 
that comprise a shapefile: SHP, SHX, DBF (and PRJ files 
for the coordinate system if you accept it -see Step-by-
Step Procedure on page 15).

- When you select the DXF import option, the program just 
imports the selected DXF file.

- When you select the MIF import option, both MIF and MID 
files for the specified GIS file are imported.



About Coordinate

Transformation

Incidentally, you can use
MobileMapper Office to
transform coordinates.

First you import your GIS
data files taking care to

comply with their coordi-
nate system require-

ment. Secondly, in
MobileMapper Office,

you select the coordinate
system in which you

would like your coordi-
nates to be expressed.
Then you just have to

export back the GIS
data, which this time will

be expressed in this
coordinate system once

exported.
What if GIS Data Import Fails
- If you click on the Import button and the selected file does 

not load into the open job file, the most likely problem is 
that the coordinate system that you selected for the 
imported GIS file is incorrect. You will see an error mes-
sage telling you that the coordinate system you selected is 
incorrect. To fix this, select File>Import, select the file for 
import and select another coordinate system that your 
organization commonly uses.

- If you wish to import several files at a time, all must be in 
the same coordinate system.

- Conversely, you CAN import files in different coordinate 
systems provided you import them one after the other. The 
important thing in this case is that, for each imported file, 
the right coordinate system be selected in the GIS Data 
Import window (see point 1. above).

- If you are unsure of what coordinate system is being used 
to display the files that are already in the job, read its 
name in the status bar (bottom right). You can also select 
Options>Select Coordinate System on the MobileMapper 
Office tool bar to read this name.

Importing Files with Compatible Feature Libraries
When importing a job file into another, the two feature 
libraries must be compatible.
If the open job has a feature library with trees and rivers in it, 
you can import any file that has other feature types in it - such 
as roads.
19
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But if the “trees” feature type in the open job has the 
attributes “height” and “species,” the attributes of the tree 
features in the imported file cannot have different attributes, 
such as “Type” or “Diameter.” This would create a feature 
library that would allow a field worker to describe trees in two 
different ways.
The idea of a feature library is to guide field workers to 
describe features in the same ways so all the feature 
descriptions are consistent and therefore analyzable in the 
GIS.

Connecting the Handheld to the PC

Using the USB Port (ProMark3 Only)
- Connect your receiver to one of the USB ports on your 

office PC using the USB cable provided with the receiver.
- Turn on the handheld by pressing the power (red) button.
- Once the ProMark3 workspace is displayed, double-tap 

the Mobile Mapping icon.
- If it is the first time you are connecting the handheld to 

the PC via USB, a PC message appears informing you that 
a new USB device has been detected and you have to 
install a new USB driver.

- Follow the instructions on the PC screen. When prompted 
to do so, browse the ProMark3 CD to select the 
“AT91_USBSer.inf” file. Then let the PC complete the 
installation of the USB driver. Once installed, USB 
appears as a new, virtual COM port. For example, if there 
are two COM ports on the PC (named COM1 and COM2), 
the USB port is likely to be named “COM3”



- Do the following on the PC:
• On the menu bar, select Options and then GPS Set-

tings...
• In the dialog box that opens, click Autodetect. 

MobileMapper Office then starts a sequence to deter-
mine the port that the receiver is connected to, as well 
as the baud rate used on the receiver side. At the end 
of this sequence, the message “Found ProMark3” 
should appear as the status of one of the ports

• Click OK to close the dialog box.

- If communication has already been established with the 
receiver during this working session and you want to make 
sure MobileMapper Office is still communicating with the 
handheld, do the following:
• On the menu bar, select Options and then GPS Set-

tings...
• In the dialog box that opens, click Test. The receiver 

then tests the data link to the receiver, indicating 
which baud rate is used during this test. The message 
“Found ProMark3” should appear as the status of the 
port connected to the handheld.

• Click OK to close the dialog box.
21
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Using the Serial Port
- Connect your receiver to one of the serial ports on your 

office PCusing a serial cable.
- Turn on the handheld. (With ProMark3, double-tap the 

Mobile Mapping icon once the workspace screen is dis-
played.)

- If you are connecting the handheld to the PC for the first 
time, do the following on the PC: 
• On the menu bar, select Options and then GPS Set-

tings...
• In the dialog box that opens, click Autodetect. 

MobileMapper Office then starts a sequence to deter-
mine the port that the receiver is connected to, as well 
as the baud rate used on the receiver side. At the end 
of this sequence, the message “Found <Receiver 
model>” should appear as the status of one of the 
ports

• Click OK to close the dialog box.

- If communication has already been established with the 
receiver during this working session and you want to make 
sure MobileMapper Office is still communicating with the 
handheld, do the following:
• On the menu bar, select Options and then GPS Set-

tings...
• In the dialog box that opens, click Test. The receiver 

then tests the data link to the receiver, indicating 
which baud rate is used during this test. The message 
“Found <Receiver model>” should appear as the sta-
tus of the port connected to the handheld.

• Click OK to close the dialog box.



Before transferring data
from MobileMapper

Office to the receiver,
make sure the receiver

currently uses the
expected storage

medium (i.e. its internal
memory or the inserted

SD card). Otherwise
change the medium on

the receiver using the
MENU key.
Uploading a Job to the Handheld

You may upload an entire job to the handheld or upload only 
a geographical portion of this job.
Uploading part of a job may be useful if for example you want 
the field operator to focus on a particular region covered by 
the job, or if you need to limit the size of the uploaded data 
because the entire job is too big to hold in the handheld.
Another way of limiting the size of the uploaded data is to 
delete the layers you do not need in the field (see Deleting 
Feature Types on page 39).
You need to use the Create Region function to select a 
geographical portion of a job.

Uploading an Entire Job
- First of all, you have to connect the handheld to the PC 

running MobileMapper Office and test the connection. 
See Connecting the Handheld to the PC on page 20.

- Open the job file in MobileMapper Office using the 
File>Open command. Job filenames are in the form 
“*.mmj”.

- On the menu bar of the MobileMapper Office main win-
dow, select File, Upload to GPS and Job.... MobileMapper 
Office then routinely searches for the right baud rate to 
communicate with the handheld.
When communication is established with the handheld, a 
message is displayed allowing you to rename the job file if 
necessary. Then click OK. This automatically starts the 
upload sequence. A dialog box keeps you informed on the 
file being transferred. A message is also displayed on the 
handheld informing you that file transfer is in progress. 
These two indications disappear from the PC and hand-
held screens when data transfer is complete.
23
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Selecting part of a job
by setting a region on
the Map Display area
IMPORTANT!

1) When you upload a job file, not only do you upload all 
the logged features contained in this job, but also the fea-
ture library attached to the job. All MMJ job files include a 
feature library.
2) Job files are always in WGS 84/lat-lon, even if you 
select some other coordinate system/datum for displaying 
features, background maps and waypoints.

Uploading Part of a Job (Job Region)
You do exactly as if you were uploading the entire job (see 
Uploading an Entire Job on page 23, first two steps) except 
that you have to do the following before selecting the 
File>Upload to GPS>Job function:

- Click  on the toolbar, drag a rectangle around the 
desired region in the Map Display area and release the 
mouse button. The limits of the region are then repre-
sented with a rectangle with hatching on the outside. You 
can still resize or reshape the rectangle by dragging its 
control points (corner and mid-side points). You can also 
move the whole rectangle by dragging the mouse cursor 
from inside the rectangle.

- When the definition of the region is okay, click outside of 
this region. The region definition is now complete and its 
limits are now represented with a thick green line. The 
selected region appears darker than the rest of the map.

- If necessary, click  again (this deletes the region you 
have just defined) to redraw the region entirely.

- Select File, Upload to GPS and Job and let MobileMapper 
Office complete the Upload phase.



NOTE 1: The Create Region function may also be used to 
define the limits of the background map you upload to the 
handheld. See Setting a Map Region on page 88.
NOTE 2: Some jobs require too much RAM space for the 
receiver to both display and edit - even if you could copy 
the unopened job file to the SD card. MobileMapper 
Office checks each job file you wish to copy to the receiver 
and returns a message “The size of current job is greater 
than available memory on your GPS unit!” when it deter-
mines that the job will require more RAM memory than is 
in the receiver.
The first thing you should consider if you see the above 
warning message is to upload a subset of the job - called a 
“job region” - into the receiver. You do this in MobileMap-
per Office by opening the job and clicking on Tools>Create 
Region. Then use your mouse to mark out a rectangle on 
the map display and highlight it by right clicking on the 
region. Then click on File>Upload to GPS and name the 
region.
With the job region highlighted, you can also click on 
File>Save Job Region to save the region as a new job file 
while leaving it as part of the original job file. You can 
alternatively click on File>Cut Job Region to cut the high-
lighted region out of the original job file and save it to a 
new job file. This allows you to cut a large job into several 
regions that individual field workers can update.
25
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When they download their jobs at the end of the day, you 
can open the original job and import all the updated job 
regions. Because cutting a job region includes all the line 
and area features that are only partially located in the 
region and cuts them out of the original job, you do not 
have to worry about two regions containing portions of the 
same feature.
This makes it impossible for two workers to update the 
same line or area feature.
When importing GIS files into an MMJ job, it is best to 
take into the field the smallest amount of data that is 
required to get the job done. This can be achieved in the 
following ways:
• Remove any feature layers that you will not update in 

the field
When you import any SHP or MIF file into an MMJ job, 
the feature and attribute schema is automatically con-
verted into a feature library. But you still have the abil-
ity to control how much of the schema is converted by 
importing just those layers you need to update in the 
field.

• Remove any attributes you will not update for any 
included feature layer
In the Import GIS Data dialog box, uncheck any fea-
ture attributes that you do not need to edit in the field.

• Put layers you will not edit into a background map



If you would like to use some feature layers in the field 
for navigation and orientation, but do not plan to 
update their attributes or locations, you can import 
them into a background map by clicking on Tools > 
Background Maps. MobileMapper Office's map screen 
will display the GIS layers you imported into the job 
superimposed over the layers you imported into the 
background map. Upload the job file (File > Upload to 
GPS > Job) and then the background map (File > Upload 
to GPS > Background Map).

Saving/Cutting a Job Region
You can save any job region as a new job using two commands 
on the File menu (see the previous section on how to create a 
job region):
- Save Job Region: Allows you to save the job region as a new 

*.MMJ file without altering the contents of the original 
open job. Note that all the features inside the job region 
are copied from the original job to the new job. Also, all 
line and area features that intersect with the limits of the 
job region are copied in their entirety to the new job.

- Cut Job Region: Allows you to save the job region as a new 
*.MMJ file while cutting the contents from the original 
open job and pasting them to the new job. All line and 
area features that intersected the limits of the job region 
are moved in their entirety to the new job.
27
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Downloading a Completed Job from the 

Handheld

MobileMapper Office uses the MobileMapper Transfer utility 
as an interface program to access the files stored on the GPS/
GIS handheld.
First of all, you have to connect the handheld to the PC 
running MobileMapper Office and test the connection. See 
Connecting the Handheld to the PC on page 20.
- On the menu bar, select File>Download from GPS. This 

opens the MobileMapper Transfer window on your screen.

The right-hand pane lists all the files present in the 
default directory (...\Docs) on your PC (see example 
above). The left-hand pane will list the files stored on the 
handheld once the connection to this device is estab-
lished.



- To connect to the handheld, on the menu bar at the top, 
select successively File>Connect>GPS Device via Cable. This 
will cause the transfer utility to routinely test which is the 
highest Baud rate supported by both the handheld and the 
PC. Once communication is established, the transfer util-
ity starts reading the content of the handheld’s memory.

- You may also transfer files from any computer drive and 
directory to another - as long as both are accessible by 
your PC - by selecting File>Connect>PC Drive. For example, 
if you insert your SD card into a card reader identified on 
your PC as the e: or f: drive, you can select this drive in 
MobileMapper Transfer and copy files from the SD card to 
another location on your PC or network.
NOTE: MobileMapper Transfer processes some data files 
during download to your PC. Generic transfer utilities such 
as Windows Explorer or ActivSync cannot do this and so 
should not be used.
After a few seconds, the window’s left-hand pane should 
list the content of the handheld’s memory.
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Whenever you download
a job from the receiver,

MobileMapper Office will
import it into any job

already open in the Map
Display area - unless the

feature library of the
downloaded job is

incompatible from that
of the open job (see page

19).

Because you typically
want to re-import a job
region that was previ-
ously excised from a

larger job, it is a good
idea to open the bigger

job in MobileMapper
Office prior to download-

ing the excised job
region. This way you will
automatically import the

job region when it is
downloaded and thus

save time.
Downloading a job file
- Drag and drop this file from the left-hand pane to the 

right-hand pane (or select the file and press the F5 
key, or use the Copy To command).

- Close the MobileMapper Transfer window. This will 
cause the downloaded job to be imported into the cur-
rently open job, provided both jobs use the same fea-
ture library. Otherwise a message will warn you that 
importing this job is impossible. If you use the CTRL-
click feature to select two or more jobs, each with the 
same feature library, all of them will be displayed in 
the Map Display area after you exit the MobileMapper 
Transfer utility. You can then use the Save As function 
in MobileMapper Office to combine multiple files 
recorded in the file into a single job file on your PC.
NOTE: If you experience any problems using 
MobileMapper Transfer to download data from the 
receiver, or from its SD card in a card reader, it some-
times helps to clear the receiver's internal memory and 
try the download again.
You can clear memory by pressing the MENU button, 
selecting the Setup option and then the Clear Memory 
option. Highlight "All" and press enter. This does not 
delete any data from your SD card. However, you will 
have to re-initialize the unit before collecting more 
data.



The Import operation performed in the job download-
ing context is similar to using the Import command 
from the File menu. With this function, the down-
loaded data will automatically add up to the data of 
the currently open job. This means that you can merge 
multiple job files created for a single project before 
exporting the whole data to your GIS. In this particular 
case, it is indeed very likely that all these job files 
were created based on the same feature library.
When you import the excised portion of a job into the 
original file (by clicking on File>Import), all the excised 
features will be re-inserted - whether or not they have 
been updated. You can then export the original job 
with the updated region (or regions) back to your GIS.

Deleting a file from the handheld
- Select this file in the left-hand pane and press the Del 

key. MobileMapper Office then asks you to confirm 
that you want to delete the file. Click Yes if that is 
what you really want to do.
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Viewing/Analyzing the Content of a Job

After downloading a completed job in MobileMapper Office as 
explained in the previous chapter, you can also open it in 
MobileMapper Office using the File>Open command. As a 
result, MobileMapper Office shows the content of this job in 
the main window.
First of all, you can see the list of layers present in this job in 
the right-hand part of the screen. Clear or check the buttons 
for the layers you want to see in the Map Display area. If 
enabled for display, the background maps shown are the one 
currently selected in the Background Map List (i.e. a vector 
and/or a raster map).
Now the main purpose of viewing a job in MobileMapper 
Office is to get a view of the features that were logged during 
field operations. If enabled for display, these features are 
represented on the Map Display area according to the viewing 
choices made for the corresponding layers. You can do more 
than just view these features. You can also view the conditions 
in which these features were logged. To do that, just click on 
these features, one after the other in the Map Display area. 
This opens a new window in which you can see the properties 
of these features.



If you access the Feature
Library Editor after open-

ing a downloaded job,
this window will show

the definition of the fea-
ture library that was

used to create the job.
Unlike a standalone fea-
ture library, you CANNOT

edit a feature library
attached to a job.
In the example below, MobileMapper Office shows the 
properties of the selected point being part of an area feature:

The Feature Properties window provides the following 
information:
• Feature name and geometry, number of points for lines 

and areas only, measurement(s), user-settable Updated 
field (see Using the Point Feature’s “Updated” Field on 
page 36). Apart from the Updated field, these are non-edit-
able properties.
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MobileMapper Office
performs all these mea-
surements using three-
dimensional, WGS-84

latitude/longitude coor-
dinates of the features.

The default units are
meters and hectares, but

other units can be
selected. You can also

display the positions of
the features using other

coordinate systems in
MobileMapper Office.
However, this will not

change the length,
perimeter and area val-

ues displayed in the Fea-
ture Properties window.

The length, perimeter
and area measurements

performed by the field
receiver are based on the

same algorithms as
those used in

MobileMapper Office.
The nature of the measurements performed is presented 
below:

Length: MobileMapper Office determines the length of 
a line feature in the same way used by the receiver: by 
estimating the distance between successive points on 
the line feature with the assumption that each point is 
on a sphere of average Earth radius. The elevations of 
the points are not factored into the equation. Thus the 
software calculates the spherical distance rather than 
the horizontal or slope distance between the succes-
sive positions. The length of the line feature is the sum 
of all these distances..
Perimeter: MobileMapper Office estimates the perime-
ter of an area feature in the same way it estimates the 
length of line features.
Area of area features: MobileMapper Office determines 
areas by estimating the area enclosed within point 
locations recorded in the field with the assumption 
that each point making up the feature is on a sphere of 
average Earth radius. Thus the area is that of a curved, 
not flat, feature.

• Observation data (non-editable): date/time, duration of 
point logging.

• Current Position for the selected point (non-editable): lati-
tude, longitude, altitude, number of satellites used, PDOP 
and correction type.
The correction type may be one of the following:
- “WAAS”
-  “RTCM”



Direction of 
travel along 
the feature

Feature offset to the 
left by distance d

d

“Real” feature
-  “Post-processed”
-  “Uncorrected” (for autonomous positions)

• Accuracy Estimation for the selected point: horizontal 
error, vertical error (non-editable).

• Offset data (editable): direction (for line or area) or bear-
ing (for point), horizontal distance, vertical distance.
This set of properties can be used to artificially move the 
receiver’s GPS antenna by a certain distance from the real 
position it occupied in the field.
For example, if the receiver  was held at 5 feet (1.52 m) 
from the ground, you can enter “-1.52” m in the vertical 
distance cell to artificially bring the GPS antenna position 
down to ground level.
Likewise, you can offset a line or area feature to the right 
or left by a certain distance that you enter in the horizon-
tal distance cell. The Left and Right directions for the off-
set are defined with respect to the direction followed by 
the field operator along the feature while logging this fea-
ture (see example opposite).

• Attributes (editable): list of attributes and values currently 
assigned to these attributes. You can freely change these 
values or enter new ones if blank.
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Using the Point Feature’s “Updated” 

Field 

When you click on any point feature in the Map Display area, 
you will see that its Feature Properties window includes a row 
containing a field named “Updated”. The content of this field 
can be user-set to “Yes” or “No”.

You can freely use this field to qualify the feature points 
present in your job. For example after revisiting a point feature 
and downloading it back to the job file in MobileMapper 
Office, you may want to tag this feature point as a revisited 
one, i.e. an updated one. To do this:
- Select the point in the Map Display area
- In the Feature Properties window, click on the down arrow 

located on the right of this field and then select “Yes.”
To make it easier for you to see at a glance which feature 
points you have previously set as “updated”, MobileMapper 
Office shows these points in inverse video on the map:



Line feature with all
individual points shown -
one of which is selected

(hollow square in the
upper left)
If you want to get rid of the “updated” information through a 
single operation, you just need to select Tools>Mark All Features 
as Not Updated and then click Yes to confirm this action. As a 
result all feature points in the job will be tagged as not 
updated (Updated=No).

Opening Several Jobs at a Time

You can open several jobs at a time on your computer. When 
you do that, you open as many instances of MobileMapper 
Office as the number of open jobs. Opening a job can simply 
be made by double-clicking on the corresponding MMJ file 
from Windows Explorer.

Individual Points in Line or Area Fea-

tures

MobileMapper Office displays each of the individual points 
making up line and area features. These individual points are 
in fact the positions that were logged by the handheld receiver 
when line and area features were visited in the field.
When the Map Display area shows line and area features, you 
can do the following:
- Show/Hide their individual points: Select Options from the 

menu bar and then check or clear the Show Feature Points 
option to respectively show or hide these points. When 
shown, these points appear as small black dots along the 
line and area features.

- Select and view the properties of any of these individual 
points: First have all individual points displayed by select-
ing Options and checking the Show Feature Points option, 
then make sure none of the buttons on the toolbar are 
active.
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After deleting the point:

Before deleting a point:
Then simply click on the desired individual point to select 
it. (The selected point appears as a hollow square.) All the 
properties of this point are now displayed in the Feature 
Properties window that opens on the right so you can read 
them. These properties are very similar to the ones you 
would read for a point feature.
To quickly display the properties of the next/previous indi-
vidual point in the selected line or area feature, respec-
tively press Shift+Right Arrow key or Shift+ Left Arrow key, 
or select View>Select Next or View>Select Previous. The Fea-
ture Properties window will be automatically refreshed to 
show the properties of the new point.

- Delete any of these individual points: After selecting the 
desired point, select Tools>Delete Feature Point, or use the 
Shift + Del key combination from the keyboard. A message 
asks you to confirm the Delete request. After clicking on 
Yes, the line or area feature is updated to reflect the 
change made. Note that the feature keeps being selected 
and it is now the next feature point -in relation to the 
deleted feature point- that is now selected.

Deleting Features

You can delete features from the Map Display area, and so 
from the open job, using the following procedure:
- Make sure none of the buttons on the toolbar are active
- Click on the feature you want to delete. The feature then 

appears surrounded by a thick pink frame
- On the menu bar, select Tools>Delete Feature, or on the key-

board, press the Del key. A warning message asks you to 
confirm the delete operation

- Click the Yes button to let MobileMapper Office delete the 
feature, or the No button to cancel this operation.



Deleting feature types or
layers amounts to chang-

ing the job’s feature
library
Deleting Feature Types

You can delete feature types from the open job using the 
following procedure:
- In the Job Properties pane, right click on the name of the 

feature type you want to delete and select Delete Feature 
Type from the pop-up menu
Or

- Select the Feature Type layer in the Layers pane (bottom 
right) and then, from the menu bar, select Tools>Delete 
Layer. A warning message asks you to confirm the delete 
operation

- Click the Yes button to let MobileMapper Office delete the 
layer, or the No button to cancel this operation.
If you click Yes, the layer disappears from the feature 
types and layers lists and all the features belonging to this 
layer disappear from the Map Display area.

Deleting some layers from a job may be useful when you want 
the field operator to focus on some features in this job, and so 
ignore all others, or if the handheld’s memory space is too low 
to let MobileMapper Office upload the entire job.
Before deleting any layer from a job, remember it may be a 
good idea to save the job as a new file in order to keep the 
original job file unchanged, i.e with ALL its layers.
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Exporting Jobs in GIS Formats

The most important processing of your field data is its export 
to a GIS. Exporting field data has two processes: conversion 
of the data files to a standard format a GIS can read and then 
the actual transfer of the file.
To convert your data into SHP, MIF, CSV or DXF, do the 
following:
- On the menu bar, select File>Open to list the job files in 

MobileMapper Office
- Select the job you want to export and click Open. The con-

tent of this job is now displayed on the screen.
- In the status bar, read the name of the currently used 

coordinate system (bottom right) and check that this sys-
tem is the one used by your GIS. If that is not the case, 
select the right one using the Options>Coordinate System.... 
command. For more information on how to select a coordi-
nate system, see Selecting a Coordinate System for the 
Open Job on page 93.
If you imported a GIS file to MobileMapper Office, 
updated it in the field and exported it back to your GIS, 
you do not have to reset the coordinate system.
Remember MobileMapper Office ALWAYS exports feature 
positions in the coordinate system currently selected for 
the job.

- On the menu bar, select File>Export.
This brings up a new window that allows you to set the 
export function (see example below).



Note that you can also
export just the job's fea-
ture library by selecting

MMF as the "File of
type."
1. Choose the export format (SHP, MIF, DXF, CSV - 
or MMF, see opposite) from the Files of type field.

2. Select the folder where to transfer the reformat-
ted data files. You can select any folder that is 
accessible by your PC - including any GIS folders 
that may be on your network.
Note that the exported files will be named auto-
matically by MobileMapper Office. The reason is 
that the files must be named to reflect the names 
of the layers present in the job.

3. Click on the Export button. Your job will be auto-
matically converted (re-formatted) and trans-
ferred to the selected folder.
If a file already exists in the selected folder with 
the same name and same GIS format extension, 
then MobileMapper Office will ask you if you want 
to overwrite this file.
The presence of such a file means that you have 
previously exported a job containing a layer with 
the same name. It is therefore your responsibility 
to decide whether the already existing file should 
be overwritten or not.

1

2

3
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GPS Metadata includes
such parameters as

Num. Sat., PDOP, Date/
Time, Duration, Correc-

tion, Horizontal Error,
Vertical Error (the last

two are available only for
those job files that were

recorded in post-process-
ing mode and then post-

processed).
- When you select the SHP option, MobileMapper Office 
converts the information recorded in a job file (MMJ) into 
the following files that comprise a Shapefile: SHP, SHX 
and DBF files. MobileMapper Office exports each feature 
type to a separate shape file whose name reflects the fea-
ture type name.

- When you select the DXF export option, the program cre-
ates a single DXF file. Each feature type is exported to a 
separate DXF layer whose name reflects the feature type 
name. Each attribute is exported into a block reference 
along with the feature. Thus attributes can be seen in 
ACAD and imported into GIS software.

- When you select the MIF export option, both MIF and MID 
files are created for each feature type. Their names reflect 
those of the exported feature types.

- If you want the GPS metadata to be exported as well, you 
should select the CSV export option. A comma-delimited 
ASCII file is then generated. You can read these CSV files 
with a large number of spreadsheet or database applica-
tions. Information on each position that is averaged into a 
point feature or connected into a line or area feature is 
displayed in rows. You can also parse them in any way you 
wish. The following files are created when using the CSV 
export option:
• For each point feature type, MobileMapper Office cre-

ates a separate CSV file containing GPS metadata and 
feature attributes. The following metadata information, 
in addition to any attributes, is exported for point fea-
tures:

Feature Latitude Longitude Altitude Num. Sat PDOP Date/Time Duration Correction



• For each line or area feature type, MobileMapper 
Office creates a set of files whose names are in the 
form <feature type name>.csv. These files include fea-
ture index and feature attributes fields. Then for each 
feature, MobileMapper Office creates a CSV file con-
taining coordinates and GPS metadata for each indi-
vidual point making up a line or area feature. These 
files are named as follows:
<Feature type name>1.csv
<Feature type name>2.csv
Where 1, 2, etc. are the feature indices found in the 
file <feature type name>.csv. You can therefore access 
the GPS metadata for each individual point making up 
a line or area feature.
The following information is exported for line features:

And for each point making up the line:

The following information is exported for area features:

And for each point making up the area: 

Feature Length Attribute #1 Attribute #2, etc.

Point Latitude Longitude Altitude Num. Sat PDOP Date/Time Duration Horz error Vert error

Feature Perimeter Area Attribute #1 Attribute #2, etc.

Point Latitude Longitude Altitude Num. Sat PDOP Date/Time Duration Horz error Vert error
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There are no limits to
the number of feature

types or feature
attributes in a feature
library. However, there

cannot be more than 20
characters in a feature

type name, such as
“road” or “tree.” There

cannot be more than 10
characters in any

attribute name, such as
“width” or “height.”

There cannot be more
than 30 characters in

any menu-style attribute
value, such as “Needs

immediate repair,” and
there cannot be more
than 20 characters in

any text-style attribute
value, such as “near

123 Main St.”
7.Using the Feature Library Editor

Introduction

MobileMapper Office allows you to create new feature type 
libraries using the Feature Library Editor.
Feature libraries are standardized description templates that 
guide field operators when describing the features they are 
mapping or inspecting.
A feature library includes a number of feature types that either 
will be mapped or inspected. Each feature type is described 
according to a set of attributes. In fact, it will be the task of 
field operators to provide an attribute value for each attribute 
of a feature, depending on what they see or measure when 
they visit this feature. The diagram below shows the general 
architecture of a feature library through a simple example.

Feature Library
Hydrant

xxx...

xxx...

Color

Height

Address

Red
(Attribute #1)

(Feature type #1)

Orange

Any value between
(Attribute #2)
(Numeric type)

(Street Address)

Gray

(Menu type)

0.0 and 1.5 m

(Attribute #3)
(Text type)

Any character string
20 char. max. in length

Op
tio

ns
 in

 th
e m

en
u

(Feature type #2)

(Feature type #n)

(Attribute values)



Point feature

Line feature

Area feature

Grid feature

NOTE: Although the Fea-
ture Library does not

support waypoints, you
can create a "Waypoint"

feature type. This allows
you to record waypoints
in the field and export
them to GIS formats.

Waypoints recorded
using the receiver's Mark

feature are not export-
able by MobileMapper

Office.
There are four different geometries for feature types:
- Point: Feature types such as trees or pipeline valves. Field 

operators should log point features in static mode, i.e. 
they should stay stationary at these points for at least one 
second.

- Line: Feature types such as roads or pipelines. Field oper-
ators should log line features in kinematic mode, i.e. they 
should start logging this type of feature at the beginning of 
the line, and then move along this line until the end where 
they should stop logging data.

- Area: Feature types like crop fields or lease boundaries.

- Grid: This feature type defines an array of evenly distrib-
uted waypoints where field operators record observations 
or make measurements using some instrument. In-depth 
information on grid features is given elsewhere (see Grid 
Mapping Utility on page 59).

There are three different types of attributes:
- Menu style: the attribute value is selected from a user-

defined menu of preset values or phrases
- Numeric style: the attribute value can only be within a 

pre-defined range of numeric values
- Text style: the attribute value is in text form and should 

not exceed the permitted length (20 characters).
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Creating a New, Standalone Feature 

Library File

There are two types of feature libraries:
-  Standalone libraries that are editable and available for 

import into any job
- Libraries associated with a specific MMJ job file - in the 

same manner that an ESRI DBF file is associated with a 
particular Shapefile.

When you use the Feature Library Editor to create a new 
library, it is a standalone library that can be edited at any time 
and imported into any number of job files. But once you 
import this library into a job, the name of the library is 
changed to that of the job. Under this new name, it cannot be 
edited except for selecting new display symbology. This is 
done to ensure that the job can always be edited in the field 
and uploaded back into the GIS with the same feature library. 
This also allows two or more jobs with the same feature library 
to be merged.
- On the menu bar, select Tools, then Feature Library Editor. 

This opens the Feature Library Editor window at the center 
of the screen.
Warning! If a job is open in MobileMapper Office’s main 
window, the Feature Library Editor window defaults to the 
feature library used in the open job. This library CANNOT 
be changed except to select different map symbols and 
drawing styles.



If you want to create a new standalone feature library 
based on the open one, you have to do the following:
- On the menu bar, select File, then Save As... A new dia-

log box opens in which you can name and choose the 
folder where to store the new feature library. The 
default folder is .../DOCS. It is a good idea to group all 
feature library files in the “DOCS” default folder. 
These files can only be saved as “mmf” files as men-
tioned in the Save as type: field.

- Enter a name for the library in the File name: field. For 
example, type in “Libr-1” and click Save. The new 
name of the feature library now appears on the left-
hand part of the Feature Library Editor window.
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Inserting New Feature Types to the 

Feature Library

- In the Feature Library Editor window, right-click on the 
feature library name and select Insert Feature. A new dialog 
box opens in which you can define the first feature type 
for the library:

- Enter a name for this feature type in the Name field.
- Indicate the type of the feature. For example, if the fea-

ture is a hydrant, select Point; if it’s a coast line, select 
Line; if it’s a lake, select Area; if it's a network of point 
locations where measurements will be taken to create a 
contour map, select Grid. Grid features are presented in 
detail in a separate chapter (see Grid Mapping Utility on 
page 59.)

- Click the Add button. The Insert Feature Type dialog box is 
re-displayed to make it easier to add a series of feature 
types to the library.

- Indicate the type of the second feature as explained above 
and then click the Add button.

- Repeat the above steps until all the feature types have 
been defined.

- After defining the last feature type, click the Close button.



Defining Feature Attributes

- Under the feature library name, in the left-hand pane of 
the Feature Library Editor window, select the first feature 
name, right-click on it and select Insert Attribute. A new 
dialog box opens where you can define the first attribute 
for the feature type:

- Enter a name for this attribute in the Name field 
- Indicate the type of the attribute value: Menu, Numeric or 

Text. If the attribute value will consist of a list of values or 
phrases that the field operator may choose from, select 
Menu; if the field operator will have to enter a number, 
select Numeric; and if the feature refers to a comment or 
any other alphanumeric string that the field operator will 
have to type in, select Text.

- Then click Add to add another attribute for the feature, or 
Close after the last attribute has been defined.

- Right-click on the next feature type on the left half of the 
window, select Insert Attribute and then define all of this 
feature type’s attributes as explained above. Click the 
Close button when you are done.

- Repeat the above steps until all the attributes have been 
defined for all the feature types present in the library.
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Defining Menu-Style Attribute Values

You define attribute values in the right-hand pane of the 
Feature Library Editor window.
- Click on the name of the first attribute of the first feature 

type. The right-hand pane of the Feature Library Editor 
window now shows a table containing the definition of this 
attribute. The highlighted cell is where you can enter the 
first attribute value for this attribute. Click on this cell.

- Type in the attribute value and press ENTER on your key-
board. A new row is added in the table where you can 
enter a second attribute value, etc.

- When you are done with the values of this attribute, click 
on the second attribute in the left-hand pane of the Fea-
ture Library Editor window. Resume the previous and 
present steps as many times as necessary.

- Example of attribute values (red, orange, gray) for one of 
the attributes (color) of a point feature (hydrant):



Defining Numeric-Style Attribute 

Values

For a Numeric-style attribute, you can define the precision, 
default value and range of possible values for the attribute 
(minimum and maximum values).

Defining Text-Style Attribute Values

For a Text-style attribute, you can define the maximum 
number of characters allowed (20 characters max.) and if you 
want any default value for the attribute.
For a Menu style attribute, you should define a list of options 
the field operator will have to choose from. You may also 
define the option that will be automatically assigned by 
default to a feature logged in the field: Right-click on the cell 
containing the desired option and then select Set Default Menu 
Item. (see below).
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Choosing the Attribute Used as a Label

You can choose which attribute of a given feature type should 
be used as a label on MobileMapper Office's Map Display 
area. This is simply done by having this attribute listed first 
for the feature type. To change the order of an attribute:

1. Select this attribute
2. Click on the Up or Down arrow button on the tool 

bar to define the new position of this attribute 
within the list.

 

1
2



Renaming a Feature Type or an 

Attribute

You can also use the Feature Library Editor to change the 
name of a feature type or attribute as explained below:
- In the left-hand pane of the Editor window, click on the 

feature type name you want to edit. This displays the Fea-
ture Type table on the right.

- Double-click on the cell containing the feature name (see 
example below) or attribute name and type in a new name.

- Press the Enter key to record the change.

From the same table, you can also change the display 
characteristics given to a feature type on the map (see next 
section).
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Twenty-two symbols are
listed in this box. The

symbol you choose here
will also be shown on

the receiver’s Map
screen during field oper-
ations dealing with fea-

tures of this type.

MobileMapper Office
does not support the

importing of point fea-
ture symbols used in

GIS applications
because these are typi-

cally proprietary.
Defining the Representation of Feature 

Type

The representation of a point feature on the map is a symbol 
that you can define as explained below:
- To the right of the Drawing Attributes row of this table, 

click . A new dialog box opens in which you can select a 
new symbol for the feature type:

Using the same procedure, you can tell MobileMapper Office 
how you want line and area features to be displayed on the 
map (see drawing attributes in the two dialog boxes below).

(Line feature)

(Area feature)



Deleting Feature Types, Attributes or 

Attribute Values

The Feature Library Editor lets you delete, in a very simple 
manner, any feature type, attribute or attribute value option 
from the open feature library.
- To delete a feature type, you just select its name and you 

press the Del key on your keyboard. Deletion is immediate 
as MobileMapper Office does not require user confirma-
tion. By deleting a feature type, you also delete all 
attributes and attribute values attached to this feature 
type.

- To delete an attribute from a feature type, expand that fea-
ture in the left-hand pane of the Feature Library Editor 
window, select the attribute you want to delete and press 
Del on your keyboard. Deletion is immediate as 
MobileMapper Office does not require user confirmation. 
By deleting an attribute, you also delete all attribute val-
ues attached to this attribute.

- To delete a Menu-style attribute value from the list of pos-
sible values, first select the concerned attribute in the 
left-hand pane of the Feature Library Editor window. Then 
in the right-hand pane of this window, highlight the cell 
containing the attribute value you want to delete and press 
Del on your keyboard. Deletion is immediate as 
MobileMapper Office does not require user confirmation.
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In order to preserve the
consistency of your jobs

over time, you are not
allowed to edit the fea-
ture library attached to
a job (unless the job is
empty). You can how-
ever edit the symbols

used to display the job
in MobileMapper Office.
Saving a Feature Library

When you are done with the definition of a feature library file, 
don’t forget to save the file by selecting File>Save on the menu 
bar of the Feature Library Editor window.

Attaching a Feature Library to a Job

When you want to attach a feature library to a GIS job, you just 
have to import this feature library into the job open in the 
main window, using the File>Import command. The feature 
types contained in the feature library will then appear as 
“layers” in that job. When you save the job, the complete 
feature library will also be saved in this job.
Similarly, when you open a job after downloading it from your 
receiver, the feature types from the library file used for that 
job will automatically appear as layers pertaining to the job. If 
you run the Feature Library Editor while a job is open, it will 
display that job's feature library. If you edit this library, you 
must save it with a different file name. If you want to review 
any other feature library while a job is open, open the Feature 
Library Editor, click on File>Open and select the desired .mmf 
file.



Importing a Feature Library from a Job 

or GIS File

Using the File>Import command in the Feature Library Editor 
window, you can import the feature library used in an existing 
job or from a MIF or SHP file.
When importing a GIS file containing more than 20 characters 
(excluding dot and extension symbols) in the name, the 
Feature Library Editor truncates all characters beyond the 
20th after displaying a warning message. If the first 20 
characters in two different imported files are identical, the 
software displays a message saying the file already exists and 
generates an “Import Failed” error message. If this happens, 
you can rename the second file so that its first 20 characters 
are not identical to any previously imported file.
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You usually have to
upload a standalone fea-

ture library file to the
handheld when this fea-

ture library has never
been used to collect
data into a job file.
Uploading a Standalone Feature 

Library File to the Receiver

- Unless already done, select Tools>Feature Library Editor to 
open the Feature Library Editor window

- Open the feature library file you want to upload using the 
File>Open... command. Feature library file names use the 
“*.mmf” extension. If you want to upload the feature 
library used in the open job, then you must save it as an 
MMF file from within the Feature Library Editor window 
before you are allowed to upload this file to the handheld.

- Ensure that the receiver is turned on and attached to the 
PC via a data cable

- On the menu bar of the Feature Library Editor window, 
select File and then Upload to GPS. MobileMapper Office 
then routinely searches for the right baud rate to commu-
nicate with the handheld (whether via USB or RS232). 
When communication is established with the handheld, 
the upload sequence is automatically started. A dialog box 
keeps you informed on the file being transferred. A mes-
sage is also displayed on the handheld informing you that 
file transfer is in progress. These two message windows 
disappear from the PC and handheld screens when data 
transfer is complete. You may also insert the receiver’s SD 
card into a card reader attached to your PC and use a file 
transfer tool such as Windows explorer to copy the feature 
library to the SD card. 



8.Grid Mapping Utility

Introduction

Working with the Grid Mapping Utility is an easy way to log 
GPS positions and GIS data at waypoints arranged in an 
evenly spaced grid. This allows you to gather measurements - 
made by field sensors such as depth sounders, chemical 
detectors and magnetometers - in an organized fashion with 
an easy-to-use navigation feature. You can then create contour 
maps with the necessary density of data while avoiding any 
gaps that might force you to return to the field.

Grid Features vs. Grid Points

The Grid Mapping Utility refers to two different grid concepts: 
grid features and grid points.
- Grid features are arrays of uniformly spaced points ori-

ented in rows and columns.
- Grid points are navigation features similar to routes. They 

are created by MobileMapper Office and uploaded to the 
handheld. You navigate to each grid point using your 
receiver’s navigation screens and record your observations 
or measurements using its data logging software.

Think of an apple orchard where the rows are about 15 feet (5 
meters) apart and each tree is about 15 feet (5 meters) apart 
from the next tree in its row. The orchard is a grid feature. The 
location of each tree is a grid point. The number of apples on 
each tree is the attribute you wish to record.
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Like a point, line or area feature, a grid feature is a feature 
geometry type. You can see the similarity in two ways:
- Just as a line or area feature is made of a string of point 

positions, a grid feature is a set of points.
- As with line and area features, a single feature type name 

corresponds to the entire grid feature. In a single job, you 
might record positions and descriptions of several line fea-
tures classified as “roads” and two area features classified 
as “lakes.” And you might use one grid feature named 
“water depth” and one named “magnetic field.”

However, line and area features differ from grid features in two 
important ways:
- The positions making up line and area features mark the 

locations of real things like roads, lakes, etc. But the 
points making up a grid feature are imaginary target loca-
tions that you navigate to.

- The attributes you record for a road or a lake pertain 
equally to each of the point positions making up feature, 
but you typically record different descriptions at each grid 
point making up the grid feature.

Setting up a Grid Feature in a Feature 

Library file

Use the Feature Library Editor window to set up a grid feature. 
To add a grid feature to the feature library:
- Right-click on the name of the feature library and select 

the Insert Feature option. Then select Grid as the feature 
type



Grid properties table
- Click on the Add button, then on the Close button.
- Then define the attributes of the point feature that you 

will record at each of the grid points. Do this as you would 
for any point, line or area feature (see Defining Feature 
Attributes on page 49 and Defining Menu-Style Attribute 
Values on page 50). Typically, these are text-type 
attributes for visual observations and numeric-type 
attributes for measurements made with instruments. But 
it is also possible to record observations using a menu-
type of attributes.

Editing the Grid Properties

When you are done adding attributes to the grid feature, you 
will see the grid symbol and the name of the grid feature in 
the tree display of the feature library. If you click on the name 
of the grid feature, you will see a two-column table on the right 
labeled “Feature Type.” This is where the default values of the 
grid feature are indicated. If you want to change any of these 
values, double-click on the value and type in a new one.

Name: Feature names like “pole,” “road” or “lake” make 
it easy to identify the geometry of point line and area fea-
tures. This is not so easy with grid features. You might find 
it helpful to insert the word “grid” into the name of grid 
features. However, there is a 15-character limit to the 
name length so you may prefer to name the grid types with 
distinctive names like “mag. field,” “H2O depth” or “CO2 
conc.”
Geometry and # of attributes: Cannot be edited
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Number of Columns /Number of Rows: The easiest way to 
determine how large the entire grid must be is to measure 
the area using a background map showing appropriate lay-
ers. You can draw a rectangle over the area to be mapped 
and measure the two sides of the rectangle in meters. 
Then divide each distance by the grid feature’s spacing. 
Imagine yourself standing at one of the two corners of the 
rectangle where the grid feature is arrayed in front of you 
and to your right. The number of columns is the length of 
the side of the rectangle to your right divided by the grid 
spacing (in meters). The number of rows is the length of 
the side of the rectangle in front of you divided by the grid 
spacing.
Heading: The default heading is 0º (due North). If you 
leave the heading at this default value it means that the 
grid feature will be arrayed to the north and east of your 
position because these are the directions in front of you 
and to your right. If you want the grid feature oriented in 
any other direction, just type in the compass direction that 
you will face when standing with the grid in front of you 
and to the right.
Grid spacing: The default value for the distance between 
adjacent grid points is 50 meters. You can set this spacing 
to any number of meters you would like. This number will 
be automatically converted to any other distance unit is 
set in the receiver.



When changing from the default 50 meters, keep in mind 
that the selected value will determine the density of mea-
surements. If this number is less than 5 meters or so, 
there is no point in using a Grid feature. Simply walk 
around and take samples by visually estimating the 
required density. If you increase the spacing, be sure the 
spacing supports the density of measurements you 
require.

Uploading the Grid Feature to the 

Receiver

You upload grid features to the receiver by uploading the 
feature library that contains this feature type. You can either 
upload the feature library as a standalone library that the user 
in the field can select to record a new job. Or you can use 
MobileMapper Office to import the feature library into a job 
created in the office. Either way, you just have to click on 
File>Upload to GPS and select the file you want to use in the 
field.
If you want to inform the field user where to begin logging the 
grid feature, just create a waypoint in MobileMapper Office by 
clicking on Tools>Place Waypoints. Make sure you change the 
name from the default “WPT001” to a name telling the user 
that this is the point of beginning for logging a grid. Then 
upload this waypoint as described in Uploading a Job to the 
Handheld on page 23. 
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Creating a waypoint
9.Using the Waypoint/Route
Editor

Introduction

The Waypoint/Route Editor allows you to easily create a list of 
waypoints that might be useful for the field operator when she/
he is performing a GIS job. For example one of these 
waypoints may help to localize a hardly visible feature.
The Waypoint/Route Editor also allows you to build new 
routes, based on the existing list of waypoints.
 

Placing Waypoints

- First of all, click the down arrow next to  on the tool bar 
and select the region where your jobs are going to take 
place. As a result, a map of your region appears on the 
Map Display area.

- On the toolbar, click  and then draw a rectangle around 
the part of the map you want to enlarge. When releasing 
the mouse, the map scale is adjusted so the Map Display 
area only shows this part of the map.

- On the toolbar, click . This opens a new window in the 
right-hand part of the window where you can edit your def-
initions of waypoints.

- Click on the Map Display area where your first waypoint 
should be located. A waypoint icon now appears on the 
map with the name of the waypoint displayed next to it 
(see example opposite).



Editing a waypoint

Defining the name and
icon of the next way-

point

Waypoint table
- In the right-upper part of the window (see example oppo-
site), you can now make changes to the definition of this 
waypoint (name, coordinates, icon, optional comment).

- Next to this definition area, you can also define the name 
and icon for the next waypoint you will create

- When you are done with the definition of the first way-
point, create the second waypoint by clicking on the map 
where this second waypoint should be located. Again, you 
can adjust the definition of this waypoint in the right-
upper part of the window, etc.
Note that a waypoint table is updated in the right-lower 
part of the window as you create new waypoints. You can 
scroll this table horizontally and edit each of the cells if 
necessary. The second column (Name) contains a check 
button allowing you to show/hide each waypoint icon & 
name on the Map Display area.

Creating Waypoints from the Waypoint 

Table

Another very quick way of creating new waypoints is to use the 
aforementioned waypoint table.
- Right-click anywhere over this table and select New Way-

point in the pop-up menu. As a result a new waypoint is 
added in the waypoint table with default parameters and 
“zero” coordinates.

- You can then edit each cell to complete the definition of 
the new waypoint. The waypoint will then appear on the 
map (if located within the area covered by this map).
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Use the View function
when you have some

difficulty finding a way-
point on the map

because there are lots of
them, or simply because
you don’t want to spend

too much time search-
ing for it.
Saving Waypoints

To save your waypoints, you just need to save the currently 
open job. When you do that and there are waypoints in the job, 
MobileMapper Office creates a separate MMW file containing 
this list of waypoints.

Finding a Waypoint on the Map

MobileMapper Office helps you locate rapidly a waypoint.
- In the waypoint table, right-click on the row containing the 

definition of the waypoint and select View. The map is 
then moved accordingly within the Map Display area so as 
to put the waypoint in question exactly in the center of the 
Map Display area.

Editing/Deleting Waypoints

Waypoints can only be edited or deleted individually from the 
waypoint table. (You cannot select a waypoint by clicking on 
its icon in the Map Display area.)
To delete a waypoint:
- Select the row containing the waypoint you want to delete
- Press the Del key or right-click on the row and select 

Delete. Waypoints are deleted instantly, without user con-
firmation.

You can also delete all the existing waypoints and routes 
through a single operation by selecting the Clear All Waypoints 
option from the Tools menu.



Creating a four-way-
point route
Building a Route

After you have created a number of waypoints as explained in 
the previous chapter, you can now define routes graphically. 
Follow the instructions below to do this.

- On the toolbar, click . This opens a new window in the 
right-upper part of the window where MobileMapper Office 
automatically creates a new route named “Route1” (if it’s 
the first one in the list). Note that MobileMapper Office 
continues to display the waypoint table below this window.

- Come back to the Map Display area and click on the way-
point that you want to define as the route’s start point

- Then click on the second point, then on the third, etc. 
Every time you click a new waypoint, “Finish” is displayed 
next to this waypoint which means you don’t have to do 
anything special to end the definition of the route. 
MobileMapper Office will “understand” that the route def-
inition is complete when you proceed to another task in 
the software.
Note that you can edit the name of the route by double-
clicking on it. You can also remove a waypoint from the 
route by right-clicking on it and selecting Delete. The Map 
Display area is then updated to reflect that change in the 
definition of the route.
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Saving Routes

To save your routes, you just need to save the currently open 
job. When saving a job with waypoints/routes displayed on the 
Map Display, MobileMapper Office creates a separate .MMW 
file containing this list of waypoints and routes. If no job is 
displayed, save the waypoints/routes as a new job file. Any 
time you want to import these waypoints/routes into any other 
job, click on File>Import.

Uploading Waypoints/Routes to the 

Receiver

This is done automatically when uploading the job containing 
these waypoints and routes. You do not need to check the 
waypoints layer (in the Layer's list) or open the Waypoints or 
Routes window. Waypoints and routes are uploaded to the 
receiver as a separate .MMW file.



MobileMapper Office
and the receiver can

create, edit and store
waypoint files. But,

because waypoints are
used only for navigation,
they can be transferred

only between the PC
and the receiver. And
because they can be

described only with a
simple text message,

they are not appropriate
for export to a GIS.

However, you can use
the Feature Library Edi-
tor to create a point fea-

ture type called
"Waypoint," add all the

attributes you need and
export these to your

GIS.
Downloading Waypoints/Routes

The waypoints and routes you create in the field can be 
directly downloaded from the receiver to MobileMapper Office 
using the procedure below.
- Connect the receiver to your PC using the serial or USB 

cable (depending on the receiver model)
- Turn on the receiver
- On MobileMapper Office, select File>Download Waypoints/

Routes. A message will then appear showing the download 
in progress. When the download is complete, you will see 
the new waypoints and routes listed in a window to the 
right of the MobileMapper Office map screen.
Note that these waypoints and/or routes have been down-
loaded into the open job, which means this operation has 
brought changes to the job (see the “*” symbol after the 
job name in the title bar). You should then select File> 
Save if you want to save the downloaded waypoints and/or 
routes into this job.
If waypoints and routes are already part of the open job, 
when you run the File>Download Waypoints/Routes function, 
MobileMapper Office will warn you that it will overwrite all 
these waypoints and routes before running the download 
operation. You then have to choose between overwriting 
the waypoints and routes or canceling the download opera-
tion. 
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10.Background Maps

Introduction

Background maps are designed to provide useful details on 
working areas. Field operators might like to see these details 
on their handheld screens as they progress in their jobs so that 
they can more easily go to the places they have to visit.
Background maps are for viewing only. You cannot edit them 
or access information on their features. They provide a 
backdrop, which gives visual orientation for your data and 
waypoint files.
Background maps are shown in the Map Display area of the 
MobileMapper Office main window. They are independent of 
jobs. Whether there is an open job or not, you can have a 
background map displayed in this area. You may create this 
background map once and then it can be used as a 
background for many jobs at a certain location.
Background maps can result from two different categories of 
data:
- GIS Data allowing vector background maps to be created
- Raster data allowing raster background maps to be cre-

ated.
You cannot merge these two categories of data in a single 
background map, but you can superimpose a vector map on a 
raster map in the Map Display area (see Defining the 
Background Displayed in MobileMapper Office on page 86).



Please, carefully read
the explanations oppo-
site to understand the
difference between a

background map
“project” and the result-

ing “background map”
on the Map Display area
Background map projects are created using the Map Editor. 
The notion of “background map project” allows you to define 
the different layers (vector maps) or images (raster maps) 
comprising the background map, plus the map name and also 
the scale setting for vector maps, and if necessary, 
georeferencing information for raster maps. Use the 
Tools>Background Maps command to access the Map Editor. 
Background map projects are saved as separate files:
- With the “mmp” extension for vector maps
- With the “rmp” extension for raster maps.
Once you have defined and saved a background map project, 
whether a vector or raster map, you will then have to use the 
Operations>Create Map command to actually build the 
background map.
Usually it takes time to create a map, so it would be a benefit 
to do that once. After the background map is created, it will 
appear in the Background Maps list with the given name, and 
it can be selected at any time as a background for various job 
data.
A background map generally consists of a base map, plus 
additional details that you can for example import from your 
GIS system or from a map database. Thus, a background map 
is either a stack of several layers or/and a set of images, but 
as opposed to layers in a job file -which you can select on the 
Map Display area- the layers composing a vector map or the 
images composing a raster map, will result in a single 
backdrop on the Map Display area, with no possibility to select 
any individual items shown on this map.
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Raster Map
Vector Map

Selected 
Region

Vector-only back-
ground map in
receiver

File>
Upload to GPS>
Background Map
When you create a vector map, you can import MIF, SHP and 
DXF files that are in any coordinate system, datum and zone. 
Those that are not included as preset systems by 
MobileMapper Office can be recreated using MobileMapper 
Office's user definable system support or imported from 
ESRI’s PRJ files.
When you create a raster map, you can import image files in 
any of the following formats: TIF, GTIF, JPG, JPEG, PNG, BMP 
and GIF
To give you greater control over what you wish to store on the 
receiver, you must upload the job and/or the background map 
separately. To upload either of them, click on File>Upload to 
GPS and then select either the job or the background map 
option. If the background shown in the Map Display area 
consists of two background maps (i.e. a vector map and a 
raster map), then only the vector map will actually be 
uploaded to the receiver (see diagram opposite).

Creating a Vector Background Map

First Steps
- On the menu bar, select Tools and then Background Maps. 

This opens the Background Maps window.
- Click on the Vector Maps tab:



The purpose of the
scale “threshold” value

is to hide the vector
map attached to the

Map Display area if you
select a scale value in
the Map Display area
that is incompatible

with the density of
details in this vector

map
- Click on the Map Editor... button. This opens the Vector 
Map Editor window from which you can create a new vec-
tor map project:

- In the Map Name field, type in a name for the vector map 
project.

- In the Map Scale field, choose the scale “threshold” value 
controlling the display of the vector map in MobileMapper 
Office. If later on, the scale setting you use in the Map 
Display area is less than this threshold value, then the 
background map will NOT be displayed.
For example, if you set the scale “threshold” value to 
1:100,000, then the background map will be displayed 
only if the scale used in the Map Display area is greater 
than this value (for example 1:50 000 or 1:10 000).
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When you import GIS
files, you have to iden-
tify the coordinate sys-
tem and datum used to

display the GIS file. You
can determine what sys-

tem was used, by dis-
playing the file in your

GIS or by asking the GIS
manager. You typically
have to ask this ques-

tion only once because
most GIS files in a

project are in the same
coordinate system.
Conversely, if the scale used by the Map Display area is 
equal to or less than 1:100 000 (e.g. 1:200 000), then 
the vector map will not be visible in the Map Display area. 
However, you will see the boundary of this vector map rep-
resented in the form of a rectangle. See also Which Scale 
to Use to Display a Vector Background Map? on page 87.
The scale “threshold” value can be set individually for 
each layer present in a vector map.

Adding Layers to a Vector Map Project
You can add as many layers as necessary to build a vector 
map. Layers may be SHP, DXF or MIF files.
If you want to import layers from an MMJ job file, first export 
the job into SHP or MIF format and then import the desired 
layers back into the vector map.

- Click , or on the menu bar, select Layer>Add... A dialog 
box opens in which you should indicate the folder where to 
find the layer and then select the file corresponding to 
that layer.

- In the combo box located in the lower part of the dialog 
box, select the coordinate system on which the layer to be 
added is based (see warning opposite).
If a PRJ file exists for the Shape file you are about to 
import, it is a good idea first to import the PRJ file from 
the Options>Browse Coordinate Systems command (see page 
100). After this operation, the corresponding coordinate 
system will be available from the Select Coordinate System 
dialog box.



- Click on the Open button. The selected file now appears as 
a layer in the first row of the Vector Map Editor window:

- Resume the previous steps as many times as necessary to 
add all the layers you need for your vector map.

- Click  (or select Operations>Create Map) to build the 
map.

- Select File and then Save or Save As. In the dialog box that 
opens, choose a folder and enter a name for the vector 
map project you have just built. This project will have the 
“mmp” extension.

- Then click the Save button to save the project.
By saving a map project, you make it possible to re-create 
a map without having to resume the steps described 
above. For example, if later on you want to change the 
appearance of a layer, you just need to re-open the map 
project, edit the layer and re-build the map.
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Changing the Order of Layers
When you build the vector map, the first layer you placed in 
the table will be brought to the front, and the last one will be 
sent to the back. Intermediate layers will occupy intermediate 
positions in the layer stack, i.e., it will be obscured by the 
layers ahead of it on the layer list.
If one of your layers contains area features, it is important that 
this layer be placed at the bottom of the table otherwise all 
layers containing point or line features located within these 
area features would be hidden by these features.
To change the position of a layer in the table:
- Highlight the row containing this layer by clicking on any 

cell in this row

- Click or , or select Layer>Move Up or Move Down to 
move up or down the layer by one row. If necessary, repeat 
this step until the layer is at the right position in the table.

Removing Layers
- Highlight the layer you want to remove

- Click , or select Layer>Remove from the menu bar, or 
press the Del key. This instantly removes the layer from 
the vector map project.



Changing the Visual Aspect of Layers
You can customize each layer by double-clicking on the 
corresponding row in the table or by using the Layer>Edit... 
command. This opens a dialog box in which you can choose 
the aspect you want for the layer when the vector map is built 
up later. As you will probably notice, the available options are 
much similar to those available when creating feature types 
with the Feature Library Editor.
- For a point feature layer, you can choose the type of icon 

that will be used to represent all the features pertaining to 
the layer

- For a line feature layer, you can choose the color and 
width of the line representing all the features pertaining to 
the layer

- For an area feature layer, you can choose whether all the 
features pertaining to this layer should be represented just 
by their outlines (in this case you choose a color for the 
outlines only, as you would for a line feature) or by opaque 
areas (in this case the color and filling style you choose 
apply to the entire area).
If the area layer you are importing consists of contiguous 
areas, such as individual parcels making up a property 
map, you must use the outline option or the individual 
areas will not be distinguishable on the Map Display.

You can also do the following for each layer:
- Edit its name
- Select which attribute to display as a label together with 

the icon or line
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The purpose of the
scale “threshold” value
is to hide the layer from

the background map
attached to the Map

Display area if you
select a scale value in
the Map Display area
that is incompatible

with the density of
details in this layer
- Change the scale “threshold” value controlling the display 
of the layer in MobileMapper Office if you want it to be 
different from the one you defined for the entire vector 
map. By default, each layer is allotted the same scale 
“threshold” value as the vector map’s (see page 73). On 
the other hand, if you want to change the scale “thresh-
old” value for a layer, then it can only be equal to or 
greater than that assigned to the vector map.

- If later on, the scale setting you use in the Map Display 
area is less than this “threshold” value, then the features 
pertaining to the layer will NOT be displayed (see also 
Which Scale to Use to Display a Vector Background Map? 
on page 87 for more details).

Building the Vector Background Map
Once you are done with adding and re-arranging layers, you 
can build the vector map from these layers.
- First save the vector map project using the File>Save com-

mand if you are happy with the project name or the 
File>Save as command if you wish to rename the vector 
map project.

- Then click , or on the menu bar, select Operations>Cre-
ate Map. MobileMapper Office then builds the vector back-
ground map. A dialog box is displayed indicating that this 
operation is in progress. It disappears from the screen 
when the build operation is complete.

- Close the Vector Map Editor window. This takes you back 
to the Background Maps window where the newly created 
vector map is already attached.



Creating a Raster Background Map

First Steps
- On the menu bar, select Tools and then Background Maps. 

This opens the Background Maps window.
- Click on the Raster Maps tab:

- Click on the Map Editor... button. This opens the Raster 
Map Editor window from which you can create a new ras-
ter map project:

- In the Map Name field, type in a name for the raster map 
project.
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Image 1

Image 2

Image 3

Resulting Raster 
Background Map
Adding/Removing Raster Data To/From a Raster 
Map Project
You can add as many images (raster data) as necessary to 
build a raster map. Raster data may be TIF, GTIF, BMP, JPG, 
JPEG, PNG or GIF files.

- Click , or on the menu bar, select Image>Add... A dialog 
box opens in which you should indicate the folder where to 
find the image, the format in which the image is saved 
and then select the file corresponding to that image.

- Click on the Open button. The selected file now appears in 
the first row of the Raster Map Editor window:

- Resume the previous steps as many times as necessary to 
add all the images you need for your raster map.
Adding several images makes sense when you would like 
to gather several sections of maps spread out all over a 
given area into a single raster map (see example opposite).
You can see through this example that adding images to a 
raster map project is not enough to thoroughly define the 
raster map: You need to position these sections of maps in 
space. This operation is usually referred to as “georefer-
encing”.



Some images, like GeoTIFF, are georeferenced by their 
distributor, so all you need to do is just add these images 
to your map project. For some other types of images, you 
will need to georeference them to further allow the soft-
ware to create the raster map (see next point.) Even if you 
have only one image in the project, you should make sure 
it is properly georeferenced and if it’s not, you will have to 
do it.

Removing Images from a Raster Map Project: If you would like 
to remove an image from the project, do the following:
- Select the row containing the image you want to remove

- Click , or select Image>Remove from the menu bar, or 
press the Del key. This instantly removes the image from 
the raster map project.

Georeferencing Images
After adding an image to the raster map project, the software 
tells you whether the image needs georeferencing or not. You 
can read this information in the Georeference column (3rd 
column):

• If the column reads “georeferenced” after adding an 
image, you have nothing more to do (the image is 
properly georeferenced)

• On the contrary, if the same column reads “0 ref. 
points” (in red), georeferencing is required
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Ref Pt 1 Ref Pt 2

Ref Pt 4 Ref Pt 5

Good Georeferencing:

Poor Georeferencing:

Ref Pt 1

Ref Pt 3
Ref Pt 2

Ref Pt 3
So what’s georeferencing an image? It means defining at least 
3 reference points giving the position of the image in space 
(i.e. on the horizontal plane used for mapping). Defining a 
reference point means entering its precise X-Y or Lat-Lon 
coordinates depending on the coordinate system used. The 
larger the number of reference points you define, the more 
evenly distributed these points over the entire image, the 
better the georeferencing of the image.
Obviously, as a prerequisite for georeferencing, you should 
collect all the known reference points -inside the area 
represented by the image- that you can use for this purpose.
To georeference an image, do the following after adding it to 
the raster map project:
- Edit the image by double-clicking anywhere inside the cor-

responding row in the Raster Map Editor window.

(You could also select the row and then click , or 
select Image>Edit... from the menu bar, to edit the image.)
This opens a full-screen window showing the image.

- Top left of this window, click on  to select the coordi-
nate system used by the known reference points. This 
opens the Select Coordinate System dialog box from which 
you can select this system. For more information on how 
to select a coordinate system, see Selecting a Coordinate 
System for the Open Job on page 93.

- After selecting the desired coordinate system, click OK to 
validate your choice and close the dialog box. You can now 
define your reference points. If necessary use the zoom in 
button to enlarge the image before defining these points.



Defining a reference
point

Reference Point icon

Note: Testing the refer-
ence points is not a pre-

requisite for building
the raster map.
- Top left of the window, click on 
- On the image, click exactly at the location where your ref-

erence point is. A new dialog box opens in which you can 
enter the name, coordinates and comments for the refer-
ence point (see opposite).

- Click OK when you have finished entering the reference 
point’s properties. This closes the dialog box. On the 
image, you can now see the reference point icon.

- Repeat the above two steps until you have placed all your 
reference points on the map.

- Click on  again to stop adding new reference points. By 
releasing this button, you make it possible to use the other 
buttons of the window’s toolbar.

Testing the reference points: After defining at least three 
reference points on the image, you can test the ability of the 
software to correctly georeference the image using these 
points:

- Now that  is available for use, click on this button. If 
the georeferencing is successful, the following message 
will be displayed on the screen: “Image was successfully cal-
ibrated”. If it’s not, you will get a message of the type: 
“Cannot calibrate image. Please verify reference points. Mini-
mum number of reference points is three.”

Viewing the properties of an already georeferenced image: 
After adding a georeferenced file to the raster map project, do 
the following to display its georeference properties:
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If you attempt to define
reference points on an
already georeferenced

image, the following
message will appear:

“Image is already georefer-
enced. Do you really want to
calibrate it?”. If you click
Yes, you will lose all the

georeference informa-
tion initially attached to
the image. You will then
have to define the coor-

dinate system used as
well as the required
number of reference

points to let the soft-
ware re-calibrate the

image. So be sure that’s
what you really want to

do before going any fur-
ther into that procedure!
- In the Raster Map Editor window’s table, double-click in 
the row containing this image. This opens a new window 
viewing the image

- Top left of the window, click on . This opens the Image 
Georeference Properties window (GeoTiff files only; see 
example below).

Managing your reference points: The window’s toolbar 
includes two more buttons that you can use after selecting a 
reference point on the image. Make sure the leftmost button 
is released otherwise you won’t be able to select any reference 
point. To select a reference point, click on the corresponding 
icon, which will then appear with green background. These 
two additional buttons are the following:

- : Allows you to delete the selected reference point

- : Allows you to display the properties of the selected 
reference point



When you have finished defining your reference points, close 
the full-display window by clicking on the cross button top 
right of the window.

Building the Raster Background Map
Do the following:

- Click  (or select Operations>Create Map) to build the 
map.

- Select File and then Save or Save As. In the dialog box that 
opens, choose a folder and enter a name for the raster 
map project you have just built. This project will have the 
“rmp” extension.

- Then click the Save button to save the project.
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Defining the Background Displayed in 

MobileMapper Office 

This function allows you to select the background map that 
you want to view in the Map Display area. You can select one 
raster map and one vector map at the same time. When you 
do that, MobileMapper Office will always bring the vector map 
in front and will send the raster map to back. The vector map 
is always transparent except in those areas containing items.
To define the background for the map display area, do the 
following:

- Click  to open the Background Maps dialog box. This 
box contains two tabs: Vector Maps and Raster Maps. Each 
tab lists the names of the existing background maps.

- On each tab, select the name of the background map you 
want to view and click on the Attach button. A clip icon 
appears before this name indicating that the attachment 
is now effective. You can only attach one map on each of 
the tabs.

- Click on the Close button. This closes the dialog box and 
displays the attached background map(s) in the Map Dis-
play area. The way the vector background map is dis-
played is discussed in the next chapter.

The following functions are also available from the 
Background Map dialog box:
- Create New...: Provides access to the Map Editor window
- Detach: Detaches from the Map Display the background 

map that is highlighted with the paper clip icon
- Remove: Deletes the highlighted background map from 

your computer.



Vector map with all its
layers displayed

Vector map when rep-
resented only by its

boundary
Which Scale to Use to Display a Vector 

Background Map?

The vector map’s layers may or may not be visible in the Map 
Display area depending on the relationship between the scale 
you choose in the Map Display and the scale threshold(s) 
defined in the vector map.
- To display all the layers of the vector background map, 

choose a scale that is greater than the greatest scale 
threshold defined in the vector map.
For example, a vector map contains three layers defined 
with the following scale threshold values: 1:10 000, 
1:25 000 and 1:50 000. (The scale threshold assigned to 
the vector map is therefore 1:50 000.) The table below 
summarizes the map scale ranges for which the different 
layers of this vector map example will actually be dis-
played.

- If you choose a map scale that is less than any of these 
threshold values, then only the boundary of the vector 
background will be displayed (see opposite).

Layer # Layer 1 Layer 2 Layer 3
Scale threshold 1:50 000 1:25 000 1:10 000

Map scale set to: Displayed Layers:
1:50 000 or less (e.g. 1:100 000) (None)

< 1:25 000 and > 1:50 000 (e.g. 1:30 000)

< 1:10 000 and > 1:25 000 (e.g. 1:15 000)

> 1:10 000 (e.g. 1:9 000)
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If one or more layers cannot be displayed owing to the 
chosen map scale, then the boundary of the vector back-
ground map will also be displayed together with those lay-
ers that are still enabled for display.

Setting a Map Region

This function allows you to define the exact limits of the 
background map –shown on the Map Display area– that you 
wish to upload to the handheld. Using this function also 
allows you to limit the file size of the uploaded portion of the 
background map for better display performance in the field.

- Click  on the toolbar, drag a rectangle around the 
desired region in the Map Display area and release the 
mouse button. The limits of the region are then repre-
sented with a rectangle. You can still resize or reshape the 
rectangle by dragging its control points (corner and mid-
side points). You can also move the whole rectangle by 
dragging the mouse cursor from inside the rectangle.

- When the location and size of the region is okay, click out-
side of this region.The region is now defined and its limits 
are represented by a thick green line.

To delete the region and start over, click .

Note: The Create Region function may also be used to 
define the geographical limits of the job you upload to the 
handheld. See Uploading Part of a Job (Job Region) on 
page 24.



Because many back-
ground maps are very

large and because most
SD card readers use the

USB communication
standard (that is faster
than the serial cable's
RS232 protocol), you
may find the SD card

upload option to be the
best way to put back-

ground maps into your
handheld.
Uploading Whole or Part of the Back-

ground

After attaching a vector and/or raster background map to the 
Map Display area and possibly setting a map region (see the 
previous two chapters), you can now proceed with the 
uploading of the background map to the handheld, to the PC’s 
hard disk or to the SD card inserted in the local SD card 
reader.
We’ll explain here how you can upload a background map. You 
have to upload jobs and background maps separately. 
Background maps are not included in the job files. Only 
feature libraries are actually written into job files. Only vector 
maps can be uploaded. If the Map Display area’s background 
consists of a raster map and a vector map, then only the vector 
map will be uploaded.
- On the menu bar, select File>Upload to GPS>Background 

Map. If no Map region has been defined previously in the 
Map Display area, a message will pop up warning you that 
the whole background map is going to be uploaded. If you 
click Yes, the procedure will continue. If you click No, the 
procedure will be aborted.
In the next dialog box that opens, you have to select the 
destination of the background map. This can be the 
receiver (GPS Unit), the local SD Card reader or the PC 
hard disk (Hard Drive).
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- Check Upload to GPS Unit and click the Next> button. If you 
have previously run the procedure described in  Connect-
ing the Handheld to the PC on page 20 to test the com-
munication with the handheld, then a new dialog box will 
be displayed reporting successful connection to the hand-
held. Otherwise, MobileMapper Office will suggest that 
you change the settings of the PC port connected to the 
handheld.

- After successful connection to the handheld, click the 
Next> button again. A new dialog box indicates the size of 
the file to be downloaded.

- You just have to click the Finish button to let MobileMap-
per Office complete the upload operation. The following 
message is displayed while the file is being uploaded: 



11.Coordinate System

Introduction to Coordinate Systems 

and Datums

For the purposes of collecting or updating map data, both 
MobileMapper Office and the receiver software will display the 
coordinates of features imported from your GIS maps in 
whatever datum you wish. This means that if you move the 
map cursor (in either MobileMapper Office or the receiver 
software) over a feature on a map screen, the coordinate 
numbers (lat/lon or northing/easting) will be displayed in the 
coordinate system/datum of your choice. This allows you to 
compare the coordinates of features on the receiver map with 
coordinates you might have in a database.
However, the receiver uses only the WGS 84 datum to project 
data onto the map screen, i.e. to position features spatially on 
a map. One way to visualize this is if you were to select NAD 
83 or ED 50 as your datum in either MobileMapper Office or 
the receiver and moved the map cursor over a feature, you 
would display coordinate numbers (lat/lon or northing/easting) 
that were calculated using this datum. If you switched to the 
WGS 84 datum, the coordinates displayed on the receiver's 
Position Screen or in MobileMapper Office suite's coordinate 
display window would change - but the position of the feature 
on the map screen would NOT change.
Why is this? Calculating coordinates doesn't take much 
computing power but using powerful map projection 
algorithms does. Moving features around on the small map 
extents used by workers in the field does not warrant any 
decrease in receiver map display performance.
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It would take an unnecessary increase in time to display a map 
that would hardly change in appearance. To re-project 
positions on a MobileMapper Office map screen using a 
variety of datums would not be a problem for the PC and its 
larger screen. However, this is a GIS function that is outside 
the scope of MobileMapper Office, which is designed as a 
GPS data communication, display and validating tool and not 
as a GIS in itself. Because Magellan does not know what 
algorithms your GIS uses for map projections, you should 
always transform your GPS positions using the same GIS you 
use to manage your existing maps. This is the best way to 
assure conformance of the positions to your GIS maps and 
databases.

Defining Coordinate Systems in 

MobileMapper Office 

Coordinate systems are organized in three different types as 
summarized in the table below:

MobileMapper Office supports the following projections:
- Transverse Mercator
- Lambert Conformal Conic 1SP
- Lambert Conformal Conic 2SP

System Coordinates Definition

Projected Easting, Northing, Height
Datum + Projection + System Defini-
tion (name, units, labels, vertical 
datum) 

Geographic Latitude, longitude, Height Datum + System Definition (name, 
units, labels, vertical datum)

Geocentric X ECEF, Y ECEF, Z ECEF Datum + System Definition (name 
units, labels)



- Oblique Stereographic
- Oblique Mercator
- Lambert Conformal Conic 27
- Oblique Mercator 27
- Transverse Mercator 27
- Transverse Mercator Alaska 27
- Transverse Mercator OSTN02 (projection grid)
- Oblique Stereographic RD2000 (projection grid)
- Ground System.
A large number of geodetic and grid systems are available for 
use. However, if none of these systems is suitable for your 
jobs, you can create a new one, based on the information you 
have to define this system. This is described in the next 
chapters.

Selecting a Coordinate System for the 

Open Job

The coordinate system assigned to a job is defined by 
selecting Options>Select Coordinate System.
This brings up a new dialog box in which you can choose the 
desired coordinate system for the job. The list of systems 
attached to the Spatial Reference System field contains at least 
the following two options:
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- Selecting <WGS 84> will directly select WGS 84 as the 
job’s coordinate system.

You can click on the  button, next to the field, to edit 
the definition of the WGS 84. If you change and enable 
any of the parameters defining the WGS 84, MobileMap-
per Office will create a new system named WGS 84~1 by 
default.

- Selecting <New> will display the following dialog box:

- If you check SELECT a PRE-DEFINED system and you click 
the Next button, MobileMapper Office will display the list 
of pre-defined systems (more than 500 are available).
In this case you just have to select a system in the right-
hand list (see example below) and click the Finish button. 



The selected system name will then appear in the Spatial 
Reference System field. From now on, this system will also 
be available from the list attached to this field.

- If you check either Define a NEW PROJECTED system or 
Define a NEW GEOGRAPHIC system, then MobileMapper 
Office will allow you to define a new system (see hereaf-
ter).

Creating a Projected System

The process of creating a new projected system goes through 
three distinct phases corresponding to three different dialog 
boxes, as explained below. To access the first of these dialog 
boxes, do the following:
- Run the Options>Browse Coordinate Systems command

- Click , check the Define a NEW PROJECTED system 
option and click the Next button. This opens the Coordinate 
System Wizard-Datum dialog box (continued below).

Defining the Datum
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- There are two different scenarios to define a datum for a 
new system:
• The new system relies on a known datum: just select a 

name from the list attached to the Datum name field. 
The rest of the dialog box (i.e. ellipsoid name and def-
inition + position in space) is updated to match your 
selection.

• The new system relies on an unknown datum: type the 
name of the new datum in the Datum name field, then 
type the name of the associated ellipsoid in the Ellip-
soid name field. Enter the semi-major axis and inverse 
flattening ratio in the next two fields and then define 
the position in space of this ellipsoid with respect to 
the WGS 84 in the remaining 7 fields.
Note that the datum and the ellipsoid that you create 
in this second scenario are also intrinsically tied to 
each other.

- When you have finished defining the datum, click the Next 
button to display the next dialog box (see below).



Defining the Projection

- Select the desired type of projection from the list attached 
to the Projection Class field, and then complete the fields 
underneath

- If the new system includes a horizontal correction, check 
the box top right. This action unveils a number of fields in 
the right-hand part of the dialog box that you must com-
plete to define the horizontal correction.

- When you have finished defining the projection, click the 
Next button to display the next dialog box (see below).
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Defining the System

- Enter the following parameters to complete the definition 
of the new projected system:
• Projected system name
• Labels associated with the three coordinates
• Unit used for horizontal coordinates (Meters, Feet or 

Survey feet). For your information, the Meters per unit 
field indicates the value, in m, of the selected unit 
(e.g. 1 foot=0.3048 m)

• Vertical datum: the “Ellipsoid” option refers to the 
ellipsoid you have selected earlier for the datum

• Unit used for vertical coordinates (Meters per unit field: 
same as above). The check box located bottom left 
allows you to define the same units for ALL coordi-
nates when checked.

• Vertical correction: check the corresponding box if the 
local system includes a vertical correction, and then 
enter the parameters defining this correction.

- Click OK to create the new system and close the dialog 
box. The new system then becomes the one selected in 
the Spatial Reference System field.



Creating a Geographic System

- Run the Options>Browse Coordinate Systems command

- Click , check the Define a NEW GEOGRAPHIC system 
option and click the Next button. This opens the Coordinate 
System Wizard-Datum dialog box.

- Follow the same procedure as when you create a projected 
system. The only difference is that you do not have to 
define a projection.

Creating a Geocentric System

- Run the Options>Browse Coordinate Systems command

- Click , check the Define a NEW GEOCENTRIC system 
option and click the Next button. This opens the Coordinate 
System Wizard-Datum dialog box.

- Follow the same procedure as when you create a projected 
or geographic system. Defining a geocentric system is 
much like defining a geographic system except that you do 
not have to define a vertical datum. 

Managing Coordinate Systems

- On the MobileMapper Office menu bar, select 
Options>Browse Coordinate Systems. The dialog box that 
opens looks like the one below:
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CSL: Coordinate Sys-
tem List file

PRJ: ESRI PRoJection
Definition file
The content of this dialog box determines the list of 
coordinate systems attached to the Spatial Reference System 
field in the dialog box that opens when you select 
Options>Select Coordinate System.
The following functions can be performed from this box:

- : After selecting a system, click on this button to edit 
the properties of this system 

- : Click on this button to add a new coordinate system 
to the list. After clicking on this button, choose the type of 
coordinate system you want to define and then define this 
system, or simply select it from the list of pre-defined sys-
tems.

- : After selecting a system in the list, click on this but-
ton to delete this system. You can only delete a pre-
defined system from this list, not from the list of pre-
defined systems. Conversely, a system you have created 
yourself will be definitively deleted from the coordinate 
system library if you delete it.

- : Click on this button if you want to import a coordi-
nate system from a file in CSL or PRJ format. After click-
ing on this button, select the file to be imported from the 
folder you choose and then click Open. The imported sys-
tem will appear in the list of coordinate systems. Files in 
CSL or PRJ format are ASCII files.

- : Click on this button after selecting the coordinate 
system you want to export. Specify the target folder, the 
export format (csl or prj) and click Save. The system is 
exported in the specified format. 
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12.Print Function

MobileMapper Office’s Print function allows you to print the 
content of the Map Display area. What will be printed will 
therefore depend on which layers you will check in the Layers 
List. Like most Windows applications, the Print Preview and 
Print Setup functions are available from the File menu.
Use Print Preview to adjust the map scale. The map scale 
control looks like a linear pot. You set the map scale by 
dragging the cursor to the desired position. The resulting scale 
value is then displayed in the field nearby and the content of 
the Map Display area is updated to reflect the change of scale.
You can also type in the desired scale (minimum 1/300) 
directly in the field nearby. After typing in the scale value, 
press the Enter key to validate it. The preview will then be 
adjusted accordingly and the cursor of the linear control will 
be brought to mid-position to reflect the newly entered scale. 
You can then adjust the scale value around the typed value 
either by dragging the cursor in either direction or by selecting 
one of the preset values -surrounding the last entered value- 
from the list attached to the scale value field.
Use Print Setup to set the page format and orientation and 
choose your printer. 
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13.Save Map function

Not only can you print the content of the Map Display area but 
you can also save it as an image file. The available formats are 
BMP, JPEG, TIFF and TGA.
To save the content of the Map Display area, use the Save Map 
Image from the File menu, choose a format and a folder where 
to save the file, name the file and click on the Save button. 



14.Post-Processing

Field Receiver (Handheld)

The Post-Processing mode allows you to enhance the accuracy 
of your feature locations from about 2-3 meters with WAAS/
EGNOS/RTCM corrections to less than one meter under 
favorable conditions (tracking > 5 satellites under an open sky 
with a PDOP < 4). This mode makes use of differential 
techniques (DGPS) to achieve this higher level of accuracy.
However, unlike unaided GPS or WAAS/EGNOS/RTCM GPS, 
the Post-Processing mode does not deliver accurate positions 
instantly. You will need to post-process your field data in 
MobileMapper Office to obtain feature locations exhibiting 
DGPS (Differential GPS) accuracy.

Basics of Post-Processed Differential 

Correction

Differential correction software removes some of the error 
inherent in the standalone GPS position determined by roving 
GPS receiver. A reference station with known coordinates 
records GPS satellite data at the same time as the rover 
receiver. Because the true coordinates of the reference 
receiver are known, the differential correction software can 
use this information to “correct” the raw measurements of the 
distance to each satellite that were recorded by the rover 
receiver. The corrected GPS measurements at any time are 
common to all GPS receivers within a few hundred kilometers 
of the reference receiver.
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If you combine the adjustments calculated for the reference 
receiver with the measurements recorded by the rover 
receivers, you can improve the accuracy of the rovers. Such 
techniques for improving GPS accuracy are called 
“differential correction.”
You can calculate and apply differential corrections in two 
ways. You can broadcast the corrections as they are calculated 
by the reference receiver in “real-time” to any rover receiver 
that is equipped with a radio to pick up the corrections. The 
rover uses a radio to receive these corrections and internal 
software to apply them to the GPS measurements it receives. 
It then differentially corrects its positions in real-time. This is 
how real-time systems such as WAAS, EGNOS or Coast Guard 
systems work. Most GPS-for-GIS receivers are equipped with 
an internal WAAS/EGNOS receiver and firmware to apply the 
corrections. They can also use beacon-type receivers such as 
the MobileMapper Beacon to pick up Coast Guard or other 
national differential GPS broadcasts.
You can alternatively download the data recorded by both the 
reference and rover receivers and use differential correction 
software on your PC to apply the corrections. This is called 
“post-processing” because the accuracy is improved after 
everything is recorded. Real-time correction systems are 
essentially transparent to the user but are limited in the level 
of accuracy they can provide. Although post-processing 
requires more effort and does not produce the results in real 
time, it is more accurate because post-processing software 
runs on more powerful computers and can go forwards and 
backwards through the data to provide more accurate 
solutions.



Field Implementation

System Requirements
Post-processing requires that you have two GPS data files 
recorded at the same time. Therefore you need two receivers:
- One is left stationary over a known control point and is 

called base or reference station. If a receiver is used as 
the reference, after making sure the receiver has calcu-
lated its position, you will activate the Reference Station 
option and then let the receiver operate on its own. The 
receiver will continually log a GPS measurements file, 
sometimes referred to as “raw data” file.

- The other is the “rover” and collects data exactly as you 
would for real-time accuracy. So you will just have to con-
centrate on your job and leave the rest to the receiver! 
With the “Post-processing” mode enabled in a job, not 
only will the receiver log GIS data in the specified MMJ 
job, but also GPS measurements in a separate file (GPS 
measurements file). This data logging function will be per-
formed as a background task that will stop when you close 
the job.

You can use the receiver as either a reference receiver or as a 
rover receiver. You can also use any Magellan receiver that 
records B-, D-, E- and W-files. But perhaps the most common 
way to obtain reference station files is to download them from 
the Internet from a public source of GPS reference receiver 
data.
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This data is usually published in the Receiver Independent 
Exchange Format or RINEX. MobileMapper Office's post-
processing differential correction module can accept 
reference station data in any of these formats.

Timing Requirement
There is a very important timing requirement that you should 
observe: The following two events (“Reference in operation” 
and “GIS data collection”) should overlap in time. See 
diagram below:

If these two events do not overlap entirely, then only the 
“common part” will be usable later in the post-processing:

Reference in operation

GIS data collection
Time

Amount of data useful for
post-processing: maximum

Time

Reference in operation

GIS data collection

Amount of data useful for
post-processing: poor



If more than one reference station file is required to 
differentially correct the rover job file, simply place all of them 
in the same directory. When you open up the rover file, all the 
appropriate reference station files will be displayed and 
MobileMapper Office will automatically use those portions of 
the files that overlap the rover file.
If the GIS operator is also the person in charge of setting up 
and operating the reference, then this timing requirement will 
naturally be met if the operator proceeds in the following 
order:
• Operator sets up the reference and puts it in operation
• Operator performs GIS data collection with the receiver
• After completing the GIS job(s), operator goes back to the 

reference, turns it off and brings the reference and rover 
files back to the office.

Where to Install the Reference
If you wish to install your own reference station, the only 
important thing is that it be sited in a location that gives a 
maximum view of the sky in all directions. Ideally, this 
location will be over a survey control point that is positioned 
with the greatest accuracy possible. Any error in the 
coordinates will be translated to the positions of all the rover 
job files.
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Accuracy Vs. Distance Between Reference and 
Rover
Accuracy is a certain minimum distance, say 50 cm to which 
you must add 1 or 2 parts per million (1 to 2 millimeters per 
km of distance between the reference and the rover). At 100 
km, you must add 10 cm to the best possible accuracy. 
Beyond 300 km, the rover will likely see a satellite that the 
reference cannot see. If this occurs, the satellite has to be 
thrown out of the solution and this could have a very negative 
impact on accuracy. So the important thing is that both 
receivers can continuously track a maximum number of 
satellites (and the same satellites).



File naming

conventions:

The first 4 characters
are the “Site ID” that

you typed into the Site
ID screen when you set

up the reference
receiver. The next let-
ter shows the number

of the reference
receiver file recorded

that day. The “05”
stands for the year

(2005). The file exten-
sion contains the num-

ber of the day in the
calendar year, e.g. “31”
designates Jan 31 and

“32” designates Feb 1.

Note: GPS measure-
ments files are split

into three or four differ-
ent files by MobileMap-
per Transfer when they
are downloaded to the
PC: B-, D-, E- and W-
files. The MobileMap-
per Office differential

correction utility needs
these types of files to
be in the same direc-

tory as the rover job
file. This occurs auto-

matically.
Downloading GPS Measurements Files 

to MobileMapper Office

To do this, you will use the same tool as the one used to 
download job files, namely the MobileMapper Transfer 
module. Downloading GPS measurements files to 
MobileMapper Office is different however depending on 
whether the connected receiver is a reference or a rover:
- After connection to a “reference” receiver, MobileMapper 

Transfer will show a new type of file marked with a yellow 
triangle icon: this is the GPS measurements file collected 
at the reference site.

To download this file, simply drag & drop it from the left-
hand pane to the right-hand pane, in the folder where you 
will also download the job file and its associated GPS 
measurements file (see below).

- After connection to a “rover” receiver, MobileMapper 
Transfer will display only the job files (.mmj), feature 
libraries (.mmf) and waypoint files (.mmw) that are 
recorded on the SD card. But when you transfer a rover job 
file, the GPS measurements file is simultaneously trans-
ferred to the same directory you select for the .mmj file.
109



110
Even after transfer is complete, MobileMapper Transfer 
will not display the GPS measurements files, but you may 
be certain that they are there. If you ever suspect that any 
of the necessary files have been moved out of the direc-
tory, you may check this using Windows Explorer. However, 
you should use only MobileMapper Transfer to transfer 
files from the receiver's SD card to your PC.

Notes: 1) Before you record any type of file, you should 
check the remaining memory on the receiver ( for 
ProMark3, in internal memory or  on SD card depending 
on which storage medium you are using). This is espe-
cially important before logging a reference station file, 
because the handheld warns you when memory is getting 
close to full. You can see this warning when recording a 
rover file, but not when recording a reference station file - 
because you won't be there.
2) When memory is full, the receiver will automatically 
close the file and no data will be lost.



There are actually four
files with every job: B,

D, E and W but only B,
W and E files from the

rover are used. There
are also four files with
every reference station

file: B, D, E and W. The
B file contains the GPS
observables, the D file
contains a file descrip-

tion - in this case the
reference file's site ID
and its averaged posi-

tion - the E-file con-
tains ephemeris data

(info on the SVs' posi-
tions in their orbits)

and the W file contains
SBAS data

NOTE: when you record
a job and close it, then
re-open it and append

more data to it, you will
see two lines in the Dif-
ferential correction win-

dow for this job. Each
line will be labeled as

“Job1” for example. You
will also see the gap

when the job was not
being recorded.
Post-Processing Phase

Remember the job file and the GPS measurements file 
collected at the reference (reference file) should have been 
downloaded to the same folder (the job folder) on your 
computer. As explained earlier, the GPS measurements file 
collected by the rover (rover file) always “follows” the job file.
If you now open the job file in MobileMapper Office, you will 
see all the DGPS-related information gathered in a new 
window located at the bottom of the MobileMapper Office 
window. This new window would not appear if the job file had 
been created with the “Real-time” option. The figure below is 
an example of what you can see in this window. A thorough 
description of this window is provided in Description of the 
Differential Correction Window on page 115.

- In the Time Bar column, check that the rover and reference 
files overlap in time. (There must be a common period of 
time during which GPS measurements files were logged 
simultaneously by the reference and the rover. Remember 
that multiple base files can be used to cover the full time 
extent of the rover files). If this requirement is met, then 
post-processing is possible.
But before starting the post-processing, you have to enter 
the exact coordinates of the control point where the refer-
ence was installed (see below). You are supposed to know 
these coordinates.
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- In the lower part of the screen, click on the row describing 
the reference station file.

- Then click on . This opens the Reference Station Infor-
mation dialog box. This dialog box looks like this:

It is very important that 
the reference station coor-
dinates displayed in this 
dialog box be as accurate 
as possible. Any error in 
the coordinates will be 
passed to each position in 
the rover file.
The first time you down-
load data from a reference 
station with the indicated 
site ID, MobileMapper 
Office will search the same 

folder for a file containing the surveyed coordinates of this 
site.
Most CORS reference files include very accurate reference 
station positions. However, if no file is found, MobileMap-
per Office will calculate an average position using the data 
recorded by the reference receiver over the duration of the 
file. Even if this file is 24 hours long, the error added to 
each of the rover positions will probably be greater than 1 
meter. You should, therefore, always check that the dis-
played coordinates are correct before proceeding with the 
post-processing.
If you can find more accurate coordinates for the refer-
ence receiver and type them into the Reference Station 
Information dialog box, MobileMapper Office will remem-
ber them and display them every time you use any refer-
ence data from a receiver with the same Site ID.



- First select the coordinate system in which the coordi-
nates of the control point are accurately known. For more 
information on how to select a coordinate system from this 
dialog, refer to the procedure described in Selecting a 
Coordinate System for the Open Job on page 93.

- Then enter the coordinates of the control point. You may 
also enter a description of the reference receiver or its 
location.

- Click OK to close the dialog box. Once you click OK, the 
coordinates last displayed in the dialog box are written 
into memory. Any subsequent file recorded with this same 
Site ID will use the coordinates you just entered.

- Click on  to start post-processing the job. A message 
box appears denoting post-processing in progress.
When the job is fully processed, the Map Display area is 
refreshed to show the changes made to the locations (and 
shapes) of your features after applying the differential cor-
rections determined by MobileMapper Office.
If you click on any of the features shown in the Map Dis-
play area, the Feature Properties window will appear show-
ing the new properties of the feature (corrected, more 
accurate coordinates, etc.).
The Feature Properties window displays the number of sat-
ellites used to calculate a position and the PDOP for that 
position. The more satellites used to calculate a position 
and the lower the PDOP, the greater the probability of 
good accuracy.
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Many factors such as tree canopy, radio emissions, tall 
buildings and steep hills can negatively affect GPS accu-
racy. If the GPS data quality is good enough to permit the 
calculation of a position but bad enough to yield a very low 
probability of good accuracy, MobileMapper Office will 
display the number of satellites as being 0 and the PDOP 
as being 200.
If you notice that some of the point features you recorded 
are missing or some of the line or area features have 
straight sections in them, this indicates that the quality of 
the data during these epochs did not permit the calcula-
tion of any position.
The Correction row indicates that the feature position is a 
post-processed DGPS Solution:



Description of the Differential 

Correction Window

The Differential Correction window contains two different 
items: a table and a toolbar.
Each row in the table depicts a GPS measurements file 
present in the job folder. The table consists of the following 
columns:

File Name: Gives the name of the GPS measurements file. 
An icon before the name tells you whether the file was 
logged by a rover or a reference receiver:

: Rover 

: Reference
Also, MobileMapper Office refers to the reference files as 
“Reference Receiver Files”. See the tool tip and the dialog 
box you see when you click on the Add Reference Station 
button.
Start Time: Date & time when the rover or reference 
receiver started logging data to the file indicated.
End Time: Date & time when the rover or reference receiver 
stopped logging data to the file indicated.
Time bar: Allows you to see at a glance if all the GPS mea-
surements files present in the job overlap. The longer the 
common periods of time, the better the post-processing 
will be. Reference files are shown in yellow, rover files in 
green. Sections of rover files that are shown in red means 
that there is no reference data available for these “red” 
periods of time.
115



116
The toolbar contains five buttons. The function of each of 
them is described below:

: Allows you to add a new reference file to the post-
processing. It makes sense to add new reference files to 
the post-processing only if these files offer additional 
observation data for the period of time covered by your 
rover file. If you attempt to add a reference file that does 
not overlap with the rover file, you will see the following 
message :

When you click on this button, a dialog box opens asking 
you to choose the reference file you wish to use. Refer-
ence files can be in two different formats: RINEX or B*.*.

: Removes the selected reference station file from the 
differential correction window. This button does not delete 
the reference file but simply removes it from the list of 
files to include in post-processing. You can always add a 
reference station that you earlier removed by clicking on 
the Add Reference Station button.



: Displays the positions of the CORS (Continuously 
Operating Reference Stations) on the map. If you display 
the world map, you will notice that this button shows/
hides ALL of the CORS operated around the world!

You can read the properties of a CORS by double-clicking 
the corresponding “small triangle” icon on the map. A dia-
log box opens in which you can read its name and coordi-
nates.
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You can download RINEX data from the indicated CORS 
station by clicking on the RINEX Download button

: Launches the RINEX Download utility allowing you 
to download GPS raw data in RINEX format, via the Inter-
net, for the reference stations you would like to use in the 
post-processing of your jobs. This function is discussed in 
detail in Downloading RINEX Data via the Internet on 
page 119.

: Edits the properties of the selected reference sta-
tion. Note that this is the reference STATION properties, 
not the properties of the file. You use this function to give 
the reference its true coordinates. Before doing this, you 
have to choose the coordinate system in which these true 
coordinates are expressed. The greater the accuracy of the 
coordinates appearing in this dialog box, the greater the 
absolute accuracy of the corrected job file.
Note that MobileMapper Office keeps in memory a list of 
existing references derived from the reference files you 
download to your job folders. It is therefore essential that 
you use a specific site ID for each control point on which 
you install a reference. Otherwise you may unintentionally 
overwrite the reference station’s coordinates. 

 : Adjusts the zoom on the Map Display area so that 
both your features and the references can be seen on the 
screen.

: Starts post-processing the displayed job file using 
data from the indicated reference receiver. If several refer-
ence files are present in the table, select the one you want 
to work with before clicking on this button. See also 
below.



Working with Several Reference Files

If MobileMapper Office detects several reference files that 
overlap with the job’s rover file, you will be asked to choose 
the file to be used in the post-processing.
But if several reference files are necessary to “cover” the rover 
file and these files do not overlap with each other (see 
example below), you do not need to select any reference file 
since all of them will automatically be involved in the 
processing.

GPS Position Display Filter

See GPS Position Display Filter on page 12.

Downloading RINEX Data via the Inter-

net

Introduction
The Rinex Download utility allows you to download RINEX raw 
data from a provider, via the web.
Rinex Download will automatically set the Start date, Start time 
and Duration fields to fit in with the rover files present in the 
open job.
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This means RINEX Download will by default ask the data 
provider to send data for the same period of time as the rover 
file.

Rinex Download is organized, and should be used, as follows:
- Provider: This field contains the Provider’s web address. 

Rinex Download provides a pre-defined list of about 10 
providers. The default selection is NGS CORS. When you 
launch Rinex Download from within MobileMapper Office 
and a station is selected, the corresponding provider will 
be selected. When you select a provider, the correspond-
ing web address is displayed in the lower part of the win-
dow (in underlined blue characters) after the “Provider 
Info:” text string. Clicking on this address would launch 
your Internet explorer to connect to this website.



- Station: This field is displayed only if you have selected a 
raw data provider in the Provider field. You then have to 
choose the station for which you want raw data.
The Load Available Base Station List button opposite this 
field allows you to ask the provider to send an up-to-date 
list of all the stations for which raw data files are col-
lected.collected. Click this button first and then select the 
station name in the Station field.

- Time Zone: Rinex Download automatically reads this infor-
mation from your computer time settings so you should 
not normally have to set this field. If you do it however, 
make sure that the daylight saving setting corresponds to 
the settings in Windows Date/Time Properties. Click this 
button first and then select the station name in the Station 
field.

- Start Date, Start Time, Duration: Same as above. These fields 
determine the period of time for which you want data from 
your provider. The End date and End time fields are software 
set for your information.
To change the Start date, click on the corresponding 
down-arrow. A calendar is then displayed:

• Click on the displayed year and use the up/down 
arrows next to it to set the year

• Click on the right/left arrow to set the month
• Click on the day number to set the day. This closes the 

calendar.
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If Rinex Download
returns the error mes-

sage “Time does not
overlap” when down-

loading data, you should
check that your com-

puter is set to the cor-
rect time (select

Start>Settings>Control
Panel>Date/Time to check

this point)
- Target Path: This field allows you to define the folder where 
you want Rinex Download to store the downloaded files.

To do this, click on , browse your disk until you can 
select the desired folder name and then click OK. The 
selected folder and its path will then appear in the Target 
Path field.

- Download button: Click on this button when you agree with 
all the settings in the window and you want to start down-
loading data. Below is an example of the message lines 
that appear in the output pane –located in the lower part 
of the window– as raw data downloading takes place:

Connecting to Host "cddisa.gsfc.nasa.gov"... Ok
Searching for file "/pub/gps/gpsdata/04013/04d/brst0130.04d.Z" ... Ok
Searching for file "/pub/gps/gpsdata/brdc/2004/brdc0130.04n.Z" ... Ok
Downloading File "/pub/gps/gpsdata/04013/04d/brst0130.04d.Z"... Ok
Downloading File "/pub/gps/gpsdata/brdc/2004/brdc0130.04n.Z"... Ok
Disconnecting... Ok
Uncompressing Observation file(s)... Ok
Merging Observation data to "brst0131.04o"... Ok
Uncompressing Navigation file(s)... Ok
Merging Navigation data to "brst0131.04n"... Ok

Note the different operations performed during this phase:
• Rinex Download connects to the Provider’s web 

address
• Provider then searches for and then download the cor-

responding files to the specified folder
• Disconnection from Provider’s web address
• Rinex Download locally uncompresses and merges the 

observation files
• Rinex Download then locally uncompresses and 

merges the navigation files.



Below is another example of messages read in the output 
pane when downloading data from an NGS CORS:

Connecting to Host "www.ngs.noaa.gov"... Ok
Searching for file "/cors/rinex/2004/232/mhcb/mhcb2320.04d.Z" ... Ok
Searching for file "/cors/rinex/2004/232/brdc2320.04n.gz" ... Ok
Downloading File "/cors/rinex/2004/232/mhcb/mhcb2320.04d.Z"... Ok
Downloading File "/cors/rinex/2004/232/brdc2320.04n.gz"... Ok
Disconnecting... Ok
Uncompressing Observation file(s)... Ok
Merging Observation data to "mhcb2321.04o"... Ok
Uncompressing Navigation file(s)... Ok
Merging Navigation data to "mhcb2321.04n"... Ok

- Close button: Click on this button to quit Rinex Download.

Adding a New Provider
See also Example of Adding a New Provider of Reference 
Station Data on page 132.
You can add more Internet sources of RINEX data by following 
the instructions below. You can also edit the properties of a 
provider or delete one that you will never use.

- Click on  located after the Provider field. This opens a 
new dialog box showing all the existing providers.

- In the lower part of this dialog box, click on the Add but-
ton. This opens a new dialog box in which you can define 
a new provider. The dialog box is slightly different depend-
ing on whether the access to the website is public or 
restricted. See the Data Type field in the screen example 
below:
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Some reference data
sites have complex

instructions for access-
ing data. If you are
working with one of

these sites, you may
have to download data

manually by visiting the
site. When you do so,

please remember to
download both the

observation files and
navigation files for the

desired time period and
make sure that the two
file names contain the

same four-character site
ID code.
This dialog box is organized and should be used as follows:
- Name: Enter the provider name or any other information 

relevant to this provider.
- Host: Enter the provider’s web address
- Data Type: Choose the type of data delivered by the pro-

vider (compact RINEX raw data).
- Time Span: (Data Duration) Rinex Download needs to know 

the period of time covered by any of the files delivered by 
this provider. Enter this time in minutes (1440 min. for 
daily data, 60 min. for hourly data, etc.). Ask your pro-
vider or consult its website if you do not know this value.

- OBS Files: Rinex Download needs to know where the files 
are stored on the provider’s website and how they are 
named.



You should then enter the path to files (example: /pub/gps/
rawdata) followed by the syntax used in the filenames. The 
“+” button located on the right of this field allows you 
enter this syntax in a more friendly way. Ask your provider 
or consult its website if you do not know the path and the 
syntax of filenames.

- NAV files: Same as OBS files field above.
- Comment: Enter your personal notes regarding the provider 

(optional)
- More Info: For example, use this field to enter the address 

of a particular page on the provider’s web site.
- Public/Restricted Access radio buttons: Choose the appropri-

ate option. If you check Restricted Access, then you will 
have to enter a username and a password in the next two 
fields.

- Log in: If you have checked Restricted Access, enter the 
username normally supplied by the provider to access his 
specified website

- Password: If you have checked Restricted Access, enter the 
password normally supplied by the provider to access his 
specified website. 
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15.Appendices

Importing Waypoints into 

MobileMapper Office

You can use MobileMapper Office to import MobileMapper 
waypoint files (.mmw), MapSend waypint files (.wpt) or 
specially formatted .txt or .xls files. There is no conversion 
module to automate the importing of files in other formats.

Importing a text file (*.txt)
In order to import a .txt waypoint file in .txt format, the file 
must contain the following information:
• A command line: "$PMGNWPL"
• A numeric field is the latitude in DDMM.MMMMM 

(Degrees.Minutes.Decimal Minutes to 5 places)
• An N (or S) for north (or south) latitude
• A second numeric field for the longitude in 

DDDMM.MMMMM format (Degrees/Minutes/Decimal 
Minutes to 5 places)

• An E (or W) for east (west) longitude
• A third numeric field (in the example below, a zero) for 

the altitude
• A field for a message (indicated in the example below 

by the letter "M")
• A field containing the waypoint's name (WPT001, 

WPT002)
• A final field containing a code for selecting an icon

After importing a file you can easily edit waypoint names, 
icons and messages in MobileMapper Office.



# Name Icon
1 WPT001 Crossed Squar
2 WPT002 Crossed Squar
3 WPT003 Crossed Squar
4 WPT004 Crossed Squar
Example of a waypoint file in .txt format:
$PMGNWPL,3721.08731,N,12156.18597,W,0,M,WPT001,,a*2D
$PMGNWPL,3721.12816,N,12156.15346,W,0,M,WPT002,,a*28

Importing an Excel file (*.xls)
It is also possible to import waypoints in Microsoft Excel 
files if the format is correct. The following is an example 
of what information must be in each column.
Note: the first row with column headers is mandatory 
(keep headers in English).

Naming Conventions for Rover

and Reference Files (Post-Processing 

Option)

Suppose you have created a new job named “JOB1.MMJ.” 
You selected the post-processing job mode in MobileMapper 
so that it records GPS measurement files in addition to 
JOB1.MMJ. The table below illustrates how these files will 
appear at various stages of the differential correction process:

Rover file seen on receiver JOB1.MMJ
Rover file seen on MobileMapper Transfer’s left 
window, before download JOB1.MMJ

Rover file seen on MobileMapper Transfer’s right 
window, after download JOB1.MMJ

Rover files seen with Windows Explorer, after 
download

JOB1.MMJ, JOB1.B00, 
JOB1.D00, JOB1.E00 and 
JOB1.W00

Rover file seen on MobileMapper Office’s Differ-
ential Correction window JOB1

Message Latitude Longitude Altitude (m) Latitude (degrees) Longitude (degrees) Icon ID
e N37°21.087’ W121°56.186’ 0 37.35145517 -121.93643283 a
e N37°21.128’ W121°56.153’ 0 37.35213600 -121.93589100 a
e N37°21.090’ W121°56.070’ 0 37.3515.367 -121.93450083 a
e N37°21.039’ W121°56.093’ 0 37.35065350 -121.93488717 a
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Suppose you have logged a reference station file on 
MobileMapper. The table below illustrates how the resulting 
files will appear at various stages of the differential correction 
process:

The rover files with a B, D, E or W in the extension represent 
files with different GPS measurements all related to the 
original rover file. MobileMapper Office handles the 
information in these files automatically. But if you archive 
your files, you should include them in the archived directories.
The reference files that start with B, D or E are similarly 
handled automatically by MobileMapper Office but should be 
archived together with the rover files.
Reference files recorded by non-MobileMapper receivers may 
have other naming conventions.

Reference file seen on receiver Not Seen

Reference file seen on MobileMapper 
Transfer’s left window, before download

0001a04.034 (for the first file 
recorded at reference station 
site ID 0001 on the 34th day of 
2004

Reference file seen on MobileMapper 
Transfer’s right window, after download

b0001a04.34, d0001a04.34,  
e0001a04.34 and w0001a04.34

Reference files seen with Windows 
Explorer, after download

b0001a04.34, d0001a04.34, 
e0001a04.34 and w0001a04.34

Reference file seen on MobileMapper 
Office’s Differential Correction window b0001a04.34



The receiver software 
allows you to define the 
full set of 9 parameters 
defining a map datum. 
After pressing MENU and 
selecting Setup>Map 
Datum>Primary/Second-
ary and “USER” in the 
prompted list, you now 
have access to two differ-
ent screens on which 
these 9 parameters are 
presented:
1st screen:

Delta A (meters)
Delta F (X 10,000)
Delta X (meters)
Delta Y (meters)
Delta Z (meters).

2nd screen (select Next> 
at the bottom of the 1st 
screen to access this 
screen):

Rotation X (sec)
Rotation Y (sec)
Rotation Z (sec)
Scale factor (ppm).
Defining a User Map Datum

Whether you are in the office using MobileMapper Office, or 
in the field working with your receiver, the system lets you 
create the user map datum you need.
However you will not use the same methods in the receiver 
and in MobileMaper Office to define the semi-major axis and 
flattening for your user datum.
In MobileMapper Office, you will use the conventional way of 
defining a user datum, i.e. by entering the semi-major axis (a), 
the inverse flattening (1/f) and the other 7 parameters.
The method used in the receiver is different as it is based on 
the use of parameters ∆a (Delta A)and ∆f (Delta F) –known as 
the Molodensky parameters– instead of a and 1/f. The other 7 
seven parameters are exactly the same as those in 
MobileMapper Office.
∆a and ∆f are defined as follows:

∆a (m) = a(WGS 84) - a(Local Datum)
∆f = f(WGS 84) - f(Local Datum)

Note that the flattening (f), instead of the inverse flattening 
(1/f), is used in the expression of ∆f. So we have:

Because the resulting ∆f is a very small quantity, it is 
multiplied by 10 000 to make it easier to handle. (The 
resulting value is closer to 1.) It is this value that you have to 
enter in the Delta F field on the handheld screen.

∆f 1
1
f
--- WGS84( )
--------------------------- 1

1
f
--- Local( )
-----------------------–=
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Calculation example:

∆a and ∆f of Frequently Used Datums

WGS 84 Local 
Datum

a 6 378 137 6 378 388
1/f 298.257 223 563 297

Complete the fields below on 
the receiver screen using the 
values of ∆a and 10000x∆f, be-
low, left):

∆a - 251 m Delta A (meters)
fWGS 84 3.352 810 665 x 10-3

fLocal 3.367 003 367 x 10-3

∆f -- 0.014 192 702 x 10-3

10 000 x ∆f - 0.141 927 02 Delta F (X10,000)

Name a 1/f Da Df x 10 000
Airy 6377563.396 299.3249646 573.604 0.11960023
Australian National 6378160.0 298.25 -23.0 -0.00081204
Bessel 1841 6377397.155 299.1528128 739.845 0.10037483
Bessel 1841 (Nambia) 6377483.865 299.1528128 653.135 0.10037483
Clarke 1866 6378206.4 294.9786982 -69.4 -0.37264639
Clarke 1880 6378249.145 293.465 -112.145 -0.54750714
Everest 6377276.345 300.8017 860.655 0.28361368
Fischer 1960 (Mercury) 6378166.0 298.3 -29.0 0.00480795
Fischer 1968 6378150.0 298.3 -13.0 0.00480795
GRS 1967 6378160.0 298.247167427 -23.0 -0.00113048
GRS 1980 6378137.0 298.257222101 0.0 -0.00000016
Helmert 1906 6378200.0 298.3 -63.0 0.00480795
Hough 6378270.0 297.0 -133.0 -0.14192702
International 6378388.0 297.0 -251.0 -0.14192702
Krassovsky 6378245.0 298.3 -108.0 0.00480795
Modified Airy 6377340.189 299.3249646 796.811 0.11960023
Modified Everest 6377304.063 300.8017 832.937 0.28361368
Modified Fischer 1960 6378155.0 298.3 -18.0 0.00480795
South American 1969 6378160.0 298.25 -23.0 -0.00081204
WGS 60 6378165.0 298.3 -28.0 0.00480795
WGS 66 6378145.0 298.25 -8.0 -0.00081204
WGS 72 6378135.0 298.26 2.0 0.0003121057
WGS 84 6378137.0 298.257223563 0.0 0.0



Shortcut Keys

Control-Z In feature library editor, undoes last deletion.
Alt-F Displays File menu items.

Alt-F-N Opens a new file in MobileMapper Office or in the 
Feature Library Editor (same as Control N).

Alt-F-O Opens an existing file in MobileMapper Office or in 
the Feature Library Editor (same as Control O).

Alt-F-S Saves the file in MobileMapper Office or in the 
Feature Library Editor (same as Control S).

Alt-F-A Saves the file open in MobileMapper Office or in 
the Feature Library Editor with a different name.

Alt-F-X Exits MobileMapper Office or the Feature Library 
Editor.

Alt-T Opens the Tools Menu.
Alt-T-F Opens the Feature Library Editor.
Alt-T-B Opens the Background Map window.

+/- key or mouse wheel Zooms in or out in Map Display area.
Shift-Left arrow / Shift-Right

arrow
Selects previous / next point in selected line or 
area feature.

Delete key Deletes selected feature.
Shift-Delete Deletes selected  individual point in line or area 

feature.
Direction keys + Control key Pans the map horizontally or vertically.
Mouse wheel + Control key Pans the map horizontally.

Mouse wheel + Shift key Pans the map vertically.
Pg Up, Pg Dwn, Home, End

keys
Pans the map diagonally.
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Example of Adding a New Provider of 

Reference Station Data

See also Adding a New Provider on page 123.
The CORS sites shown on the map display area are part of the 
following CORS networks:
- International GPS Service
- National Geodetic Survey (United States)
- Réseau GPS Permanent (France)
You can add other networks and their providers and also 
automatically download their data. There are two 
requirements:
• First, the reference station data must be available as indi-

vidual files listed on an ftp site. MobileMapper Office can-
not access data available from Worldwide Web pages, 
although it is possible to manually download such files for 
post-processing.

• Second, the data files must be named according to certain 
conventions.



For example, month codes must consist of either two digits or 
three characters (see list below).

Note that codes are provided between brackets. When 
inputting file name conventions into MobileMapper Office, 
you must type in both the brackets and the letters in between 
exactly in the same way as listed above. 
Note that codes are case-sensitive when you type them into 
MobileMapper Office because the path names on most ftp 
sites are case-sensitive. The permissible ranges are indicated 
between parentheses.

[d] 1-digit day of week (0-6, Sunday is 0)

[dd] 2-digit day of month (00-31)

[ddd] 3-digit day of year (001-366)

[h] 1-char RINEX file hour (a-x, where a = 00 GMT and x = 23 GMT)

[hh] 2-digit hours (00-23)

[mm] 2-digit minutes (00-59)

[MM] 2-digit month (01-12)

[MO] 2-character month (e.g., JA-DE for sites using English)

[Mon] 3-character month (e.g., Jan-Dec for sites using English)

[S] 1-character site ID (upper case)

[ssss] 4-character site ID (lower case)

[SSSS] 4-character site ID (upper case)

[wwww] 4-digit GPS week number (e.g., 1047)

[y] 1-digit year (0-9)

[yy] 2-digit year (00-99)

[yyyy] 4-digit year (e.g., 2005)
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CORS data providers may describe their file naming rules in a 
file posted on the ftp site, e.g. ftp://www.ngs.noaa.gov/cors/
README.txt or on pages you can find on providers’ web sites, 
e.g. http://igscb.jpl.nasa.gov/components/dcnav/
cddis_data_daily_yym.html.
You can, in a more empirical way, find the data structure used 
by providers on their sites, for example by locating the 
required data and then parsing the syntax of the downloadable 
file name so you can deduce the parameters you have to 
specify in RINEX Download’s Add Provider dialog box.
To illustrate the process of adding a CORS data provider to the 
list of supported providers, we will use the IGS Global Data 
Centre (IGS GDC) - IGNI (Institut Géographique National - 
France) as an example.
Manually locate the daily data you need, e.g.:
ftp://igs.ensg.ign.fr/pub/igs/data/2005/270/artu2700.05d.Z 
as the Observation file and:
ftp://igs.ensg.ign.fr/pub/igs/data/2005/270/artu2700.05n.Z 
as the Navigation file.
By analyzing the syntax of these links, it is easy to fill in the 
different parameters required in RINEX Download’s Add 
Provider dialog box:
FTP Host: igs.ensg.ign.fr
OBS Files: /pub/igs/data/[yyyy]/[ddd]/[ssss][ddd]0.[yy]d.Z
NAV Files: /pub/igs/data/[yyyy]/[ddd]/[ssss][ddd]0.[yy]n.Z
Time Span: 1440 min. for daily data.



Here is another example using as provider the IGS Regional 
Data Centre (IGS RDC) - BKGI (Federal Office of Carthography 
and Geodesy - Germany)
Example of downloadable Observation file:
ftp://igs.ifag.de/IGS/obs/2005/270/ajac2700.05d.Z
Navigation file:
ftp://igs.ifag.de/IGS/obs/2005/270/ajac2700.05n.Z
Or a global Navigation file merged from all IGS sites:
ftp://igs.ifag.de/IGS/BRDC/2005/270/brdc2700.05n.Z

The resulting RINEX Download entries to be used in the Add 
Provider dialog box are:
FTP Host: igs.ifag.de
OBS Files: /IGS/obs/[yyyy]/[ddd]/[ssss][ddd]0.[yy]d.Z
NAV Files: /IGS/BRDC/[yyyy]/[ddd]/brdc[ddd]0.[yy]n.Z
Time Span: 1440 min. for daily data.

Mission Planning Utility

Mission planning is a separate utility provided along with 
MobileMapper Office that you can launch from the Windows 
task bar (select Start>Programs>MobileMapper Office>Mission 
Planning)
Mission Planning allows you to know which GPS satellites 
should be visible from a given observation point on the surface 
of the Earth, and for a given period of time (max. 24 hours).
Please refer to the on-line User's Guide that is accessed via 
the program's Help menu to know more about this utility. 
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Glossary

Attribute: A description item of a feature.
Attribute value: One of the possible values that can be ascribed to a 
feature.
Base Station: See Reference Station.
B-File: A binary MobileMapper data file containing
GPS measurement data.
Carrier phase data: Phase angle measurements for the 1575 MHz ra-
dio wave carrying the GPS coded messages. Using carrier phase data 
greatly improves GPS accuracy.
Datum: A mathematical definition of a surface from which coordi-
nates of a given system are referenced.
D-File: A binary MobileMapper data file created by field collection 
software and stored in the receiver.
DGPS: Differential Global Positioning System. Commonly used to re-
fer to real-time differential correction techniques.
Differential Correction: The process of:
(1) calculating how much to adjust GPS measurements to reduce the 
difference between a location's surveyed coordinates and the coordi-
nates calculated by a GPS receiver that is kept stationary over that 
point; and
(2) the application of these adjustments to the GPS measurements re-
corded by any number of receivers within a few hundred kilometers of 
the "reference receiver."
Differential GPS: See DGPS.
E-File: A binary MobileMapper data file containing GPS ephemeris 
data.
Ephemeris Data: Information transmitted from a satellite which al-
lows the GPS receiver to determine the satellite’s position in space.
Export: Converting field data files to GIS Formats and writing them to 
any directory visible to the PC.
Feature: Any element located in the field that you wish to record for 
further uploading into a GIS database for example. A feature can rep-
resent a real object (streetlight, park, electrical transformer, etc.) or 
on the contrary, something invisible or impalpable (gas, noise level, 
dose of fertilizer, etc.).
Each new feature that you log in the field can only be an “emanation” 
or “offshoot” of one of the feature types described in the feature type 
library associated with the job in progress. The logging procedure will 
be different depending on the type of the feature you are logging.

To log a feature: Means to save the characteristics of a feature 
into the receiver’s memory. The user is in charge of entering the 
description of this feature whereas the receiver is responsible for 
saving the GPS position(s) it has determined on this feature.
To describe a feature: Means to give each attribute of the feature 
one of the prompted values for this feature.

Feature Library: A file containing all the feature types required for a 
given job. (In fact we should say “Feature Type Library”.)



Feature Type: An item present in a feature library. Each feature type 
is defined by a geometry type, a name, a certain number of possible 
attributes and the list of possible values for each attribute. There are 
four different geometries in feature types: point, line, area and grid.
Field: Any area on MobileMapper’s screen dedicated to displaying the 
value of a parameter. Some fields are user-editable, some others are 
not.
Geographic Information System: A system of digital maps, data anal-
ysis software and a database of features, attributes and geographic lo-
cations.
GIS: See Geographic Information System.
Global Positioning System: A system of satellites providing worldwide 
coverage for positioning information. Although installed and main-
tained by the United States, the broadcast signals are available to 
anyone anywhere in the world.
GPS: See Global Positioning System
GPS satellite geometry: The satellite distribution at a given location. 
measured by the PDOP index
GPS signal multipath: Occurs when the GPS signal arrives at the an-
tenna by a path other than a straight line. Multipath signals make the 
receiver think that a GPS satellite is farther away than it is and the 
resultant position is inaccurate.
Job file: File containing a feature type library and a collection of fea-
tures that grows as you log new features in the field with this job file 
open. All the features in the job file necessarily “originate” from the 
feature types present in the job file’s feature type library.
Nesting: This word is used to describe a feature that you are logging 
whereas another feature is already being logged.
PDOP: Positional Dilution of Precision. An accuracy factor derived 
from the geometry of the constellation of GPS satellites used to cal-
culate a position. In general, the more widely distributed the satellites 
are in the sky, the greater the accuracy. In general, PDOPs less than 
10 are good.
Post-processing: Differential corrections applied to GPS positions in 
a PC - after both rover and reference data are logged and downloaded. 
Post-processing is slower but more accurate than real-time differen-
tial correction.
RTCM: Radio Technical Commission for Maritime Services. Common-
ly refers to a format of real-time DGPS format.
Reference Station: A stationary GPS receiver logging, or broadcasting, 
data from a known point. The data is used for differential correction. 
Reference Station is synonomous with Base Station.
RINEX: Receiver Independent Exchange Format. A “universal” GPS 
measurement data format designed to allow compatibility b tween dif-
ferent brands of GPS receivers.
Shapefile: A set of GIS files invented by ESRI but published as an 
open file standard readable by most GISs. A shapefile consists of a 
map file (SHP),  a file containg feature descriptions (DBF), a file re-
lating the map locations with the feature description (SHX)  and 
sometimes a file containing coordinate system information (PRJ).
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Waypoint: A pre-determined coordinate point to which a GPS receiver 
can navigate. GPS receivers can also log waypoints in the field for lat-
er navigation. GPS for GIS receiver have largely replaced waypoints 
with point features.
WGS-84 coordinate system: World Geodetic System, 1984. The coor-
dinate system is used by GPS receivers for computing their positions. 
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